summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-10 08:38:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-10 08:38:10 +0000
commit87f9d548d2f4c488e4674018d8c9a484fd48cba8 (patch)
treea7ee5d288a30a28e575cd7a9d71756eb6bb91f2f /dev-ml
parentversion bump (diff)
downloadgentoo-2-87f9d548d2f4c488e4674018d8c9a484fd48cba8.tar.gz
gentoo-2-87f9d548d2f4c488e4674018d8c9a484fd48cba8.tar.bz2
gentoo-2-87f9d548d2f4c488e4674018d8c9a484fd48cba8.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog7
-rw-r--r--dev-ml/async/async-111.25.00.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index a3f2d0b8878f..2f05c3374207 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.11 2014/10/30 16:37:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.12 2014/11/10 08:38:10 aballier Exp $
+
+*async-111.25.00 (10 Nov 2014)
+
+ 10 Nov 2014; Alexis Ballier <aballier@gentoo.org> +async-111.25.00.ebuild:
+ version bump
30 Oct 2014; Alexis Ballier <aballier@gentoo.org> -async-109.35.00.ebuild,
-async-109.38.00.ebuild, -async-109.60.00.ebuild:
diff --git a/dev-ml/async/async-111.25.00.ebuild b/dev-ml/async/async-111.25.00.ebuild
new file mode 100644
index 000000000000..cf3b173f1ed5
--- /dev/null
+++ b/dev-ml/async/async-111.25.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-111.25.00.ebuild,v 1.1 2014/11/10 08:38:10 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}