summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-05-12 09:07:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-05-12 09:07:48 +0000
commita5bda8e69c6a39eaab88a55883f7ee7c8d583211 (patch)
tree96e0b29086bcb3a8766e252ae557c0e2622b55b7 /dev-ml
parentamd64 stable, bug 170299 (diff)
downloadgentoo-2-a5bda8e69c6a39eaab88a55883f7ee7c8d583211.tar.gz
gentoo-2-a5bda8e69c6a39eaab88a55883f7ee7c8d583211.tar.bz2
gentoo-2-a5bda8e69c6a39eaab88a55883f7ee7c8d583211.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/files/digest-ocamlnet-2.2.73
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.7.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 5c579903e5ae..4cd4f68b49a5 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.16 2007/03/27 18:15:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.17 2007/05/12 09:07:48 aballier Exp $
+
+*ocamlnet-2.2.7 (12 May 2007)
+
+ 12 May 2007; Alexis Ballier <aballier@gentoo.org> +ocamlnet-2.2.7.ebuild:
+ Version bump
*ocamlnet-2.2.4 (27 Mar 2007)
diff --git a/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.7 b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.7
new file mode 100644
index 000000000000..9d7699025bf5
--- /dev/null
+++ b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.7
@@ -0,0 +1,3 @@
+MD5 ff42de69d6f3803fa4ae2cdd52cb3c78 ocamlnet-2.2.7.tar.gz 1844956
+RMD160 0b0864f9536c367bb48b72973987a35bcc4c349e ocamlnet-2.2.7.tar.gz 1844956
+SHA256 88401fad6f5e656f31cccd8ed1d5576d3f0a29c2645a84a88ba17de4d9ce6d44 ocamlnet-2.2.7.tar.gz 1844956
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.7.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.7.ebuild
new file mode 100644
index 000000000000..0d2f1dde58e4
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.7.ebuild,v 1.1 2007/05/12 09:07:48 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl tk httpd"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND="!dev-ml/equeue
+ !dev-ml/rpc
+ !dev-ml/netclient
+ >=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( dev-ml/ocaml-ssl )"
+
+pkg_setup() {
+ if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
+ then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
+ fi
+}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+
+ emake -j1 all opt || die "make failed"
+}
+
+src_install() {
+ findlib_src_install
+}