summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-27 07:44:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-27 07:44:57 +0000
commite43d60ee4d048f4d6dde778ab4f6b52af6699895 (patch)
tree86cacd419b7aa7a6c36cd55662371d25d4bd5079 /dev-ml
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-e43d60ee4d048f4d6dde778ab4f6b52af6699895.tar.gz
gentoo-2-e43d60ee4d048f4d6dde778ab4f6b52af6699895.tar.bz2
gentoo-2-e43d60ee4d048f4d6dde778ab4f6b52af6699895.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocurl/ChangeLog7
-rw-r--r--dev-ml/ocurl/ocurl-0.7.5.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index 31b9c15c61d3..ed9499707ce7 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocurl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.24 2015/06/28 15:24:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.25 2015/07/27 07:44:57 aballier Exp $
+
+*ocurl-0.7.5 (27 Jul 2015)
+
+ 27 Jul 2015; Alexis Ballier <aballier@gentoo.org> +ocurl-0.7.5.ebuild:
+ version bump
28 Jun 2015; Alexis Ballier <aballier@gentoo.org> -ocurl-0.5.3.ebuild,
-ocurl-0.5.6.ebuild, -files/ocurl-0.5.1-asneeded.patch:
diff --git a/dev-ml/ocurl/ocurl-0.7.5.ebuild b/dev-ml/ocurl/ocurl-0.7.5.ebuild
new file mode 100644
index 000000000000..a90d65af981e
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.7.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.7.5.ebuild,v 1.1 2015/07/27 07:44:57 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/"
+LICENSE="MIT"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1537/${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+KEYWORDS="~amd64 ~x86"
+
+src_compile()
+{
+ emake -j1 all
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc CHANGES.txt README
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}