summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-13 03:32:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-13 03:32:15 +0000
commite350799fab9eb3415567607f561f9e6539bf3eb8 (patch)
treef7223f2dae3eb39ed805d8057122574a614a25ae /dev-perl/Inline
parentarm/hppa/ia64 lovin (diff)
downloadgentoo-2-e350799fab9eb3415567607f561f9e6539bf3eb8.tar.gz
gentoo-2-e350799fab9eb3415567607f561f9e6539bf3eb8.tar.bz2
gentoo-2-e350799fab9eb3415567607f561f9e6539bf3eb8.zip
arm/hppa/ia64 stable
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-perl/Inline')
-rw-r--r--dev-perl/Inline/Inline-0.44-r1.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/dev-perl/Inline/Inline-0.44-r1.ebuild b/dev-perl/Inline/Inline-0.44-r1.ebuild
index 16cd367f85ba..94869925792d 100644
--- a/dev-perl/Inline/Inline-0.44-r1.ebuild
+++ b/dev-perl/Inline/Inline-0.44-r1.ebuild
@@ -1,45 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/Inline-0.44-r1.ebuild,v 1.13 2005/02/01 11:07:42 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/Inline-0.44-r1.ebuild,v 1.14 2005/03/13 03:32:15 vapier Exp $
inherit perl-module eutils
DESCRIPTION="Write Perl subroutines in other languages"
-SRC_URI="http://www.cpan.org/authors/id/I/IN/INGY/${P}.tar.gz"
HOMEPAGE="http://search.cpan.org/doc/INGY/Inline-0.43/Inline.pod"
+SRC_URI="http://www.cpan.org/authors/id/I/IN/INGY/${P}.tar.gz"
-SLOT="0"
LICENSE="Artistic"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa mips"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86"
IUSE="gtk2"
-DEPEND="${DEPEND}
- dev-perl/Digest-MD5
+DEPEND="dev-perl/Digest-MD5
dev-perl/File-Spec
dev-perl/Parse-RecDescent
dev-perl/Test-Harness"
src_unpack() {
unpack ${P}.tar.gz
-
cd ${S}
#gtk-2 suggested patch
- if use gtk2
- then
- epatch ${FILESDIR}/gtk2-patch.diff
- fi
-
+ use gtk2 && epatch ${FILESDIR}/gtk2-patch.diff
}
src_compile() {
-
echo "y" | perl-module_src_compile
perl-module_src_test
}
-
-src_install () {
-
+src_install() {
perl-module_src_install
dohtml DT.html
}