summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-03-16 16:17:01 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-03-16 16:17:01 +0000
commit4300614aece30739225f5e0c6ea1b685ccd05df3 (patch)
tree2376ff16e63bd81211ae06d1ca7f4669fba89c25 /dev-perl/Net-RawIP
parentmodule-build dep (diff)
downloadgentoo-2-4300614aece30739225f5e0c6ea1b685ccd05df3.tar.gz
gentoo-2-4300614aece30739225f5e0c6ea1b685ccd05df3.tar.bz2
gentoo-2-4300614aece30739225f5e0c6ea1b685ccd05df3.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-perl/Net-RawIP')
-rw-r--r--dev-perl/Net-RawIP/ChangeLog7
-rw-r--r--dev-perl/Net-RawIP/Manifest12
-rw-r--r--dev-perl/Net-RawIP/Net-RawIP-0.2.ebuild38
-rw-r--r--dev-perl/Net-RawIP/files/digest-Net-RawIP-0.21
4 files changed, 47 insertions, 11 deletions
diff --git a/dev-perl/Net-RawIP/ChangeLog b/dev-perl/Net-RawIP/ChangeLog
index 1160d4c42391..7ca0db84bbff 100644
--- a/dev-perl/Net-RawIP/ChangeLog
+++ b/dev-perl/Net-RawIP/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Net-RawIP
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/ChangeLog,v 1.7 2005/01/29 21:16:16 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/ChangeLog,v 1.8 2005/03/16 16:17:01 mcummings Exp $
+
+*Net-RawIP-0.2 (16 Mar 2005)
+
+ 16 Mar 2005; Michael Cummings <mcummings@gentoo.org> +Net-RawIP-0.2.ebuild:
+ Version bump from cpan. bug me if it works for you so we can unmask
30 Jan 2005; Daniel Black <dragonheart@gentoo.org> Net-RawIP-0.09d.ebuild,
Net-RawIP-0.1.ebuild:
diff --git a/dev-perl/Net-RawIP/Manifest b/dev-perl/Net-RawIP/Manifest
index aa7ba188f8fe..6d69e5efd132 100644
--- a/dev-perl/Net-RawIP/Manifest
+++ b/dev-perl/Net-RawIP/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 fd2c5b0bcf7ab24000c4b1891d39db6e ChangeLog 925
MD5 4de1063eb292e8948a41b7770e71b369 Net-RawIP-0.09d.ebuild 1534
MD5 cb7a03950f80ca24532b4a5b4816193d Net-RawIP-0.1.ebuild 1551
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 8d5cf71f0b695c22bf1262ad70966858 Net-RawIP-0.2.ebuild 1445
MD5 e04c3fa53d9d22a11b1deb98b8fca6f1 files/digest-Net-RawIP-0.09d 66
MD5 ddbdc35d582bfa957c8346ece75890f5 files/digest-Net-RawIP-0.1 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB+/0mmdTrptrqvGERAsfpAJ9W6i+0s722Tn9YmWrkqtO64mFtcwCeOdMV
-bz1kYqUzWd2/4jVKSoW0gR8=
-=70pt
------END PGP SIGNATURE-----
+MD5 1ff7bc542d0a1b4c0efcefc1d1d1358a files/digest-Net-RawIP-0.2 64
diff --git a/dev-perl/Net-RawIP/Net-RawIP-0.2.ebuild b/dev-perl/Net-RawIP/Net-RawIP-0.2.ebuild
new file mode 100644
index 000000000000..d6004967f940
--- /dev/null
+++ b/dev-perl/Net-RawIP/Net-RawIP-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/Net-RawIP-0.2.ebuild,v 1.1 2005/03/16 16:17:01 mcummings Exp $
+
+inherit perl-module
+
+IUSE=""
+DESCRIPTION="Perl Net::RawIP - Raw IP packets manipulation Module"
+SRC_URI="mirror://cpan/authors/id/S/SK/SKOLYCHEV/${P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/"
+
+DEPEND="virtual/libpcap >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~alpha"
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch makes sure CFLAGS are applied properly instead of
+ # being runon additions to the previously defined symbol.
+ # Attempts to address the problem in bug 16388 without completely
+ # losing CFLAGS. The patch submitted to that bug chose to remove
+ # the $ENV{'CFLAGS'}. With the current state of MakeMaker, this
+ # would be a perfectly acceptable choice, because the approach
+ # taken here ends up with two sets of CFLAGS in the compile line.
+ # However, I believe that it may be more prudent in the long run
+ # to try to accommodate what I think the original intention of the
+ # Makefile was. Perhaps on some system with some (maybe future)
+ # version of MakeMaker, this would be the only way to convey
+ # CFLAGS. Since duplication of CFLAGS is harmless, I'm going to
+ # go with adding the space instead of taking out the $ENV{CFLAGS}.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.08
+
+ sed -i -e "s/D_IFLIST_'\./D_IFLIST_ '\./" ${S}/Makefile.PL || die "problem fixing makefile"
+}
diff --git a/dev-perl/Net-RawIP/files/digest-Net-RawIP-0.2 b/dev-perl/Net-RawIP/files/digest-Net-RawIP-0.2
new file mode 100644
index 000000000000..e99bae000cd3
--- /dev/null
+++ b/dev-perl/Net-RawIP/files/digest-Net-RawIP-0.2
@@ -0,0 +1 @@
+MD5 d64c07647e4aa1a0b80e153ec351e9c5 Net-RawIP-0.2.tar.gz 32483