summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-17 13:33:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-17 13:33:07 +0000
commit450bae556b29e5aaa8916861eaf8ae63c7c5aea0 (patch)
tree98cd41ce7be9b17b712e2b5c74d949bd2addfd5a /dev-perl/SOAP-Lite
parentBump (diff)
downloadgentoo-2-450bae556b29e5aaa8916861eaf8ae63c7c5aea0.tar.gz
gentoo-2-450bae556b29e5aaa8916861eaf8ae63c7c5aea0.tar.bz2
gentoo-2-450bae556b29e5aaa8916861eaf8ae63c7c5aea0.zip
Bump
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog7
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.040.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index d45c76a99dff..938c9283233b 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.86 2013/01/06 15:18:41 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.87 2013/08/17 13:33:07 patrick Exp $
+
+*SOAP-Lite-1.040.0 (17 Aug 2013)
+
+ 17 Aug 2013; Patrick Lauer <patrick@gentoo.org> +SOAP-Lite-1.040.0.ebuild:
+ Bump
06 Jan 2013; Torsten Veller <tove@gentoo.org> -SOAP-Lite-0.714.0.ebuild:
Cleanup
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0.ebuild
new file mode 100644
index 000000000000..ee5a6f555c0a
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0.ebuild,v 1.1 2013/08/17 13:33:07 patrick Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.04
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="
+ dev-perl/Class-Inspector
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}