summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-07-15 18:38:06 +0000
committerTorsten Veller <tove@gentoo.org>2009-07-15 18:38:06 +0000
commitb0cdbaad07de812f26f0536e6204d7d0fb51ced8 (patch)
tree33c0dc126e6bfc11c9f6ae45c61efa0439e24ae6 /dev-perl/WWW-Mechanize
parentVersion bump (diff)
downloadgentoo-2-b0cdbaad07de812f26f0536e6204d7d0fb51ced8.tar.gz
gentoo-2-b0cdbaad07de812f26f0536e6204d7d0fb51ced8.tar.bz2
gentoo-2-b0cdbaad07de812f26f0536e6204d7d0fb51ced8.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.58.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 32f9953f81f6..310bd4498fd6 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.58 2009/07/11 07:43:56 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.59 2009/07/15 18:38:06 tove Exp $
+
+*WWW-Mechanize-1.58 (15 Jul 2009)
+
+ 15 Jul 2009; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.58.ebuild:
+ Version bump
*WWW-Mechanize-1.56 (11 Jul 2009)
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.58.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.58.ebuild
new file mode 100644
index 000000000000..6de4167b8d6d
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.58.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.58.ebuild,v 1.1 2009/07/15 18:38:06 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.829
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_unpack() {
+ perl-module_src_unpack
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+}