summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-23 15:25:24 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-23 15:25:24 +0000
commit1c1ce15388a790d9c13af2c7cf7fd0180357df32 (patch)
tree9373ae133361b186ffe2ff534319e0206312c723 /dev-perl/math-pari
parentold (diff)
downloadgentoo-2-1c1ce15388a790d9c13af2c7cf7fd0180357df32.tar.gz
gentoo-2-1c1ce15388a790d9c13af2c7cf7fd0180357df32.tar.bz2
gentoo-2-1c1ce15388a790d9c13af2c7cf7fd0180357df32.zip
First import of math-pari, needed for ssh/crypt function in perl
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog10
-rw-r--r--dev-perl/math-pari/files/digest-math-pari-2.0105002
-rw-r--r--dev-perl/math-pari/files/digest-pari-2.1.41
-rw-r--r--dev-perl/math-pari/files/digest-pari-2.1.51
-rw-r--r--dev-perl/math-pari/math-pari-2.010500.ebuild21
5 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
new file mode 100644
index 000000000000..589a75b79bf7
--- /dev/null
+++ b/dev-perl/math-pari/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/math-pari
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.1 2003/06/23 15:25:24 mcummings Exp $
+
+*math-pari-2.010500 (23 Jun 2003)
+
+ 23 Jun 2003; Michael Cummings <mcummings@gentoo.org>
+ math-pari-2.010500.ebuild:
+ First import of math-pari, needed for ssh/crypt function in perl
+
diff --git a/dev-perl/math-pari/files/digest-math-pari-2.010500 b/dev-perl/math-pari/files/digest-math-pari-2.010500
new file mode 100644
index 000000000000..d2d15dba5aa6
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-math-pari-2.010500
@@ -0,0 +1,2 @@
+MD5 6ae5d0b044984a4fdc7817e79922419e Math-Pari-2.010500.tar.gz 91295
+MD5 194e9d1cc11926e457028c6a7cba15f0 pari-2.1.5.tar.gz 1540679
diff --git a/dev-perl/math-pari/files/digest-pari-2.1.4 b/dev-perl/math-pari/files/digest-pari-2.1.4
new file mode 100644
index 000000000000..ab4749a2bf91
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-pari-2.1.4
@@ -0,0 +1 @@
+MD5 f790435b3008b3a5054989fa467c5a51 pari-2.1.4.tar.gz 1539118
diff --git a/dev-perl/math-pari/files/digest-pari-2.1.5 b/dev-perl/math-pari/files/digest-pari-2.1.5
new file mode 100644
index 000000000000..2e0d53a28384
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-pari-2.1.5
@@ -0,0 +1 @@
+MD5 194e9d1cc11926e457028c6a7cba15f0 pari-2.1.5.tar.gz 1540679
diff --git a/dev-perl/math-pari/math-pari-2.010500.ebuild b/dev-perl/math-pari/math-pari-2.010500.ebuild
new file mode 100644
index 000000000000..a488a14d2937
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010500.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010500.ebuild,v 1.1 2003/06/23 15:25:24 mcummings Exp $
+
+inherit perl-module
+
+MY_P=Math-Pari-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+#PARI_VERSION=`best_version app-sci/pari`
+PARI_VERSION=2.1.5
+SRC_URI="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://www.gn-50uma.de/ftp/pari-2.1/pari-${PARI_VERSION}.tar.gz"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ~alpha ~ppc ~sparc"
+
+DEPEND="app-sci/pari"
+