summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-05-19 22:47:35 +0000
committerRobert Coie <rac@gentoo.org>2003-05-19 22:47:35 +0000
commit280dd0134feeeadb7e184fa2b563829b2b7609fd (patch)
tree4566cc6a9d3871d4fb64b83e9b5b12b86368802a /dev-perl/mod_perl
parentnew version 'n cleanup (diff)
downloadgentoo-2-280dd0134feeeadb7e184fa2b563829b2b7609fd.tar.gz
gentoo-2-280dd0134feeeadb7e184fa2b563829b2b7609fd.tar.bz2
gentoo-2-280dd0134feeeadb7e184fa2b563829b2b7609fd.zip
upstream version bump, enable make test
Diffstat (limited to 'dev-perl/mod_perl')
-rw-r--r--dev-perl/mod_perl/ChangeLog8
-rw-r--r--dev-perl/mod_perl/Manifest14
-rw-r--r--dev-perl/mod_perl/files/digest-mod_perl-1.99.091
-rw-r--r--dev-perl/mod_perl/mod_perl-1.99.09.ebuild102
4 files changed, 124 insertions, 1 deletions
diff --git a/dev-perl/mod_perl/ChangeLog b/dev-perl/mod_perl/ChangeLog
index d5052066e46e..a3389a9caf08 100644
--- a/dev-perl/mod_perl/ChangeLog
+++ b/dev-perl/mod_perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/mod_perl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/ChangeLog,v 1.16 2003/03/01 17:53:39 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/ChangeLog,v 1.17 2003/05/19 22:47:27 rac Exp $
+
+*mod_perl-1.99.09 (19 May 2003)
+
+ 19 May 2003; <rac@gentoo.org> mod_perl-1.99.09.ebuild:
+ Upstream version bump, enable "make test". Major kudos to Corporate Gadfly
+ <corporate_gadfly@hotmail.com> in bugs #19951 and #20124.
*mod_perl-1.27-r2 (01 Mar 2003)
diff --git a/dev-perl/mod_perl/Manifest b/dev-perl/mod_perl/Manifest
new file mode 100644
index 000000000000..ed266a19d520
--- /dev/null
+++ b/dev-perl/mod_perl/Manifest
@@ -0,0 +1,14 @@
+MD5 5e977dd585573935537b30815496f329 mod_perl-1.99.09.ebuild 3506
+MD5 cceb6380b449f30437760ea958461a7a mod_perl-1.27.ebuild 1426
+MD5 99cb07d1bf9c18b7ce11fbaafaf377a3 mod_perl-1.27-r2.ebuild 1818
+MD5 257dd559c301a159cf1ad5f329dcdcc9 mod_perl-1.99.08.ebuild 1239
+MD5 822d29c9240907578de0784a31af9ed6 mod_perl-1.27-r1.ebuild 1432
+MD5 06a995e2ddade1c85db18119bcd791d5 ChangeLog 2237
+MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r1 65
+MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r2 65
+MD5 4869c6ea8e02d871a03455d28b6f6cfb files/digest-mod_perl-1.99.08 68
+MD5 5fb9123a821e261a210c5fca0ff94976 files/digest-mod_perl-1.99.09 68
+MD5 39a4d91d1d90d32f90dea3c00a1680d7 files/apache2-mod_perl-startup.pl 483
+MD5 2415e6be73ba155382b34b5e2fad4951 files/75_mod_perl.conf 247
+MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27 65
+MD5 1e0341f9b7bd3c3f74c25e60eb3188c8 files/mod_perl-1.27-ipv6.patch 1207
diff --git a/dev-perl/mod_perl/files/digest-mod_perl-1.99.09 b/dev-perl/mod_perl/files/digest-mod_perl-1.99.09
new file mode 100644
index 000000000000..27be864f0d50
--- /dev/null
+++ b/dev-perl/mod_perl/files/digest-mod_perl-1.99.09
@@ -0,0 +1 @@
+MD5 475a62af71425e71552f0062ee6b8d6f mod_perl-1.99_09.tar.gz 912283
diff --git a/dev-perl/mod_perl/mod_perl-1.99.09.ebuild b/dev-perl/mod_perl/mod_perl-1.99.09.ebuild
new file mode 100644
index 000000000000..a95eaa8093bb
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.99.09.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.99.09.ebuild,v 1.1 2003/05/19 22:47:27 rac Exp $
+
+DESCRIPTION="An embedded Perl interpreter for Apache2"
+HOMEPAGE="http://perl.apache.org/"
+
+NEWPV=$(echo $PV | perl -pe 's/\.([^.]+)$/_\1/')
+NEWP="${PN}-${NEWPV}"
+S=${WORKDIR}/${NEWP}
+SRC_URI="http://perl.apache.org/dist/${NEWP}.tar.gz"
+DEPEND="dev-lang/perl =net-www/apache-2* >=dev-perl/CGI-2.93"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="1"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+
+ # I am not entirely happy with this solution, but here's what's
+ # going on here if someone wants to take a stab at another
+ # approach. When userpriv compilation is off, then the make
+ # process drops to user "nobody" to run the test servers. This
+ # server is closed, and then the socket is rebound using
+ # SO_REUSEADDR. If the same user does this, there is no problem,
+ # and the socket may be rebound immediately. If a different user
+ # (yes, in my testing, even root) attempts to rebind, it fails.
+ # Since the "is the socket available yet" code and the
+ # second-batch bind call both run as root, this will fail.
+
+ # The upstream settings on my test machine cause the second batch
+ # of tests to fail, believing the socket to still be in use. I
+ # tried patching various parts to make them run as the user
+ # specified in $config->{vars}{user} using getpwnam, but found
+ # this patch to be fairly intrusive, because the userid must be
+ # restored and the patch must be applied to multiple places.
+
+ # For now, we will simply extend the timeout in hopes that in the
+ # non-userpriv case, the socket will clear from the kernel tables
+ # normally, and the tests will proceed.
+
+ # If anybody is still having problems, then commenting out "make
+ # test" below should allow the software to build properly.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.06
+
+ sed -i -e "s/sleep \$_/sleep \$_ << 2/" ${S}/Apache-Test/lib/Apache/TestServer.pm
+}
+
+src_compile() {
+ perl Makefile.PL \
+ PREFIX=${D}/usr \
+ MP_TRACE=1 \
+ MP_DEBUG=1 \
+ MP_AP_PREFIX=/usr \
+ MP_USE_DSO=1 \
+ MP_INST_APACHE2=1 \
+ MP_APXS=/usr/sbin/apxs2 \
+ CCFLAGS="${CFLAGS} -fPIC" \
+ INSTALLDIRS=vendor </dev/null || die
+
+ emake || die
+
+ # make test notes whether it is running as root, and drops
+ # privileges all the way to "nobody" if so, so we must adjust
+ # write permissions accordingly in this case.
+
+ if [ "`id -u`" == '0' ]; then
+ chown nobody:nobody ${WORKDIR}
+ chown nobody:nobody ${T}
+ fi
+
+ # these next two stanzas avoid sandbox problems with make test
+ # tell mod_cgid to make the socket here instead of /var/run/cgisock
+ echo "ScriptSock logs/cgisock" >> ${S}/t/conf/extra.conf.in
+ echo "ScriptSock logs/cgisock" >> ${S}/ModPerl-Registry/t/conf/extra.conf.in
+ # tell CGI.pm to create new tmpfiles in this directory
+ echo "SetEnv TMPDIR ${T}" >> ${S}/t/conf/extra.conf.in
+
+ make test || die
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install \
+ MODPERL_AP_LIBEXECDIR=${D}/usr/lib/apache2-extramodules \
+ MODPERL_AP_INCLUDEDIR=${D}/usr/include/apache2 \
+ MP_INST_APACHE2=1 \
+ INSTALLDIRS=vendor || die
+
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/75_mod_perl.conf \
+ ${FILESDIR}/apache2-mod_perl-startup.pl
+
+ dodoc ${FILESDIR}/75_mod_perl.conf Changes \
+ INSTALL LICENSE README STATUS
+ cp -a docs ${D}/usr/share/doc/${PF}
+ cp -a todo ${D}/usr/share/doc/${PF}
+}