summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-13 11:56:24 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-13 11:56:24 +0000
commit72d3104702bfd77a9c0c26dbdbac1977f92bc776 (patch)
tree7fe2ce3ef994a373fcb5817ffd944f5870f1d220 /dev-perl/perl-tk
parentSet empty DOCS to avoid any useless documentation from being installed as thi... (diff)
downloadgentoo-2-72d3104702bfd77a9c0c26dbdbac1977f92bc776.tar.gz
gentoo-2-72d3104702bfd77a9c0c26dbdbac1977f92bc776.tar.bz2
gentoo-2-72d3104702bfd77a9c0c26dbdbac1977f92bc776.zip
dev-perl/perl-tk: Version Bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-perl/perl-tk')
-rw-r--r--dev-perl/perl-tk/ChangeLog8
-rw-r--r--dev-perl/perl-tk/files/perl-tk-804.31.0-xorg.patch43
-rw-r--r--dev-perl/perl-tk/perl-tk-804.31.0.ebuild40
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-perl/perl-tk/ChangeLog b/dev-perl/perl-tk/ChangeLog
index dadb1d2b4d38..9f8d2ed1bf39 100644
--- a/dev-perl/perl-tk/ChangeLog
+++ b/dev-perl/perl-tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/perl-tk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/ChangeLog,v 1.88 2013/03/03 10:17:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/ChangeLog,v 1.89 2013/08/13 11:56:24 jlec Exp $
+
+*perl-tk-804.31.0 (13 Aug 2013)
+
+ 13 Aug 2013; Justin Lecher <jlec@gentoo.org> +perl-tk-804.31.0.ebuild,
+ +files/perl-tk-804.31.0-xorg.patch:
+ Version Bump
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> perl-tk-804.29.0.ebuild,
perl-tk-804.30.0.ebuild:
diff --git a/dev-perl/perl-tk/files/perl-tk-804.31.0-xorg.patch b/dev-perl/perl-tk/files/perl-tk-804.31.0-xorg.patch
new file mode 100644
index 000000000000..2bad0ba092d5
--- /dev/null
+++ b/dev-perl/perl-tk/files/perl-tk-804.31.0-xorg.patch
@@ -0,0 +1,43 @@
+ myConfig | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/myConfig b/myConfig
+index e0ace45..be52a82 100755
+--- a/myConfig
++++ b/myConfig
+@@ -307,7 +307,7 @@ if ($win_arch eq 'x') {
+ }
+ close(XMKMF);
+ while (defined $uidir) {
+- last unless ($uidir =~ s!^.*-I(\S+)/lib/X11/config!!o);
++ last unless ($uidir =~ s!^.*-I(\S+)/lib(64)/X11/config!!o);
+ $try = $1;
+ $try =~ s/'x11root'/$ENV{X11ROOT}/;
+ push(@xdirs,$try);
+@@ -356,7 +356,7 @@ if ($win_arch eq 'x') {
+ #
+ unless (defined $xlib)
+ {
+- $xlib = &lX11(0,chooseX11(</usr/X11*/lib>),chooseX11(</usr/lib/X11*>),</usr/Xfree*/lib>,'/usr/X386/lib')
++ $xlib = &lX11(0,chooseX11(</usr/X11*/lib>),chooseX11(</usr/lib/X11*>),</usr/Xfree*/lib>,'/usr/X386/lib','/usr/lib64')
+ }
+
+ #
+@@ -375,7 +375,7 @@ if ($win_arch eq 'x') {
+ exit 0;
+ }
+
+- ($base) = $xlib =~ m#-L(.*)(?:/lib)$#x;
++ ($base) = $xlib =~ m#-L(.*)(?:/lib(64))$#x;
+ if (defined $X11INC)
+ {
+ $xinc = &IX11("$X11INC");
+@@ -387,6 +387,8 @@ if ($win_arch eq 'x') {
+ {
+ warn "Cannot find X include files via $base/include\n";
+ $xinc = &IX11(map("$_/include",@xdirs),
++ chooseX11(</usr/include/X11*>),
++ '/usr/include',
+ '/usr/openwin/include',
+ chooseX11(</usr/X11*/include>),
+ chooseX11(</usr/include/X11*>),
diff --git a/dev-perl/perl-tk/perl-tk-804.31.0.ebuild b/dev-perl/perl-tk/perl-tk-804.31.0.ebuild
new file mode 100644
index 000000000000..582867ac1b3a
--- /dev/null
+++ b/dev-perl/perl-tk/perl-tk-804.31.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/perl-tk-804.31.0.ebuild,v 1.1 2013/08/13 11:56:24 jlec Exp $
+
+EAPI=5
+
+MY_PN=Tk
+MODULE_AUTHOR=SREZIC
+MODULE_VERSION=804.031
+inherit multilib perl-module
+
+DESCRIPTION="A Perl Module for Tk"
+
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXft
+ media-libs/freetype
+ >=media-libs/libpng-1.4
+ virtual/jpeg"
+RDEPEND="${DEPEND}"
+
+# No test running here, requires an X server, and fails lots anyway.
+SRC_TEST="skip"
+PATCHES=( "${FILESDIR}"/${P}-xorg.patch )
+
+src_prepare() {
+ MAKEOPTS+=" -j1" #333049
+ myconf=( X11ROOT=${EPREFIX}/usr XFT=1 -I${EPREFIX}/usr/include/ -l${EPREFIX}/usr/$(get_libdir) )
+ mydoc="ToDo VERSIONS"
+
+ perl-module_src_prepare
+ # fix detection logic for Prefix, bug #385621
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" myConfig || die
+ # having this around breaks with perl-module and a case-IN-sensitive fs
+ rm build || die
+}