summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-05-06 08:02:42 +0000
committerTorsten Veller <tove@gentoo.org>2010-05-06 08:02:42 +0000
commit01a3ba822757a24191d2e0e22367658230537a72 (patch)
tree683dd6f0cdd3992c6004455cabec89c0569aa19e /dev-perl
parentMask libdjconsole wrt #309809. (diff)
downloadgentoo-2-01a3ba822757a24191d2e0e22367658230537a72.tar.gz
gentoo-2-01a3ba822757a24191d2e0e22367658230537a72.tar.bz2
gentoo-2-01a3ba822757a24191d2e0e22367658230537a72.zip
Used the wrong version as base: add prefix changes
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog5
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.835.ebuild24
2 files changed, 22 insertions, 7 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 57516b4e0cae..a2e2975c45e8 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.126 2010/05/06 06:29:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.127 2010/05/06 08:02:42 tove Exp $
+
+ 06 May 2010; Torsten Veller <tove@gentoo.org> libwww-perl-5.835.ebuild:
+ Used the wrong version as base: add prefix changes
*libwww-perl-5.835 (06 May 2010)
diff --git a/dev-perl/libwww-perl/libwww-perl-5.835.ebuild b/dev-perl/libwww-perl/libwww-perl-5.835.ebuild
index b74e62c78189..0d2f8bdda230 100644
--- a/dev-perl/libwww-perl/libwww-perl-5.835.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-5.835.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.835.ebuild,v 1.1 2010/05/06 06:29:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.835.ebuild,v 1.2 2010/05/06 08:02:42 tove Exp $
-EAPI=2
+EAPI=3
MODULE_AUTHOR=GAAS
inherit perl-module
@@ -10,7 +10,7 @@ inherit perl-module
DESCRIPTION="A collection of Perl Modules for the WWW"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ssl"
DEPEND="virtual/perl-libnet
@@ -25,8 +25,20 @@ RDEPEND="${DEPEND}"
src_install() {
perl-module_src_install
- dosym /usr/bin/lwp-request /usr/bin/GET
- dosym /usr/bin/lwp-request /usr/bin/POST
- dosym /usr/bin/lwp-request /usr/bin/HEAD
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
}
#SRC_TEST=do