summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-04-07 10:13:47 +0000
committerTorsten Veller <tove@gentoo.org>2012-04-07 10:13:47 +0000
commit5a0bbec51ccf19366503fb760d958b8b661dafcc (patch)
tree1ba915ff234db8e47aac25ad311f5318279c9b6e /dev-perl
parentsome plugins gives false positive results on gettext handling, add this plugi... (diff)
downloadgentoo-2-5a0bbec51ccf19366503fb760d958b8b661dafcc.tar.gz
gentoo-2-5a0bbec51ccf19366503fb760d958b8b661dafcc.tar.bz2
gentoo-2-5a0bbec51ccf19366503fb760d958b8b661dafcc.zip
[bump] dev-perl/WWW-Shorten-3.30.0
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/WWW-Shorten/ChangeLog9
-rw-r--r--dev-perl/WWW-Shorten/WWW-Shorten-3.30.0.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-perl/WWW-Shorten/ChangeLog b/dev-perl/WWW-Shorten/ChangeLog
index 2b210e12b36b..69fd2723e3b1 100644
--- a/dev-perl/WWW-Shorten/ChangeLog
+++ b/dev-perl/WWW-Shorten/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Shorten
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/ChangeLog,v 1.9 2011/09/04 11:23:24 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/ChangeLog,v 1.10 2012/04/07 10:13:47 tove Exp $
+
+*WWW-Shorten-3.30.0 (07 Apr 2012)
+
+ 07 Apr 2012; Torsten Veller <tove@gentoo.org> +WWW-Shorten-3.30.0.ebuild:
+ Version bump
04 Sep 2011; Torsten Veller <tove@gentoo.org> -WWW-Shorten-3.20.ebuild:
Cleanup
diff --git a/dev-perl/WWW-Shorten/WWW-Shorten-3.30.0.ebuild b/dev-perl/WWW-Shorten/WWW-Shorten-3.30.0.ebuild
new file mode 100644
index 000000000000..1760955b9f78
--- /dev/null
+++ b/dev-perl/WWW-Shorten/WWW-Shorten-3.30.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/WWW-Shorten-3.30.0.ebuild,v 1.1 2012/04/07 10:13:47 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DAVECROSS
+MODULE_VERSION=3.03
+inherit perl-module
+
+DESCRIPTION="Interface to URL shortening sites"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/URI"
+DEPEND=">=virtual/perl-Module-Build-0.380.0"
+# test? ( ${RDEPEND}
+# dev-perl/Test-Pod
+# dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST=online
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i -e '/Config::Auto/d' "${S}"/Build.PL || die
+}
+
+src_install() {
+ perl-module_src_install
+
+ docinto example
+ dodoc "${S}"/bin/shorten
+ rm -f "${D}"/usr/bin/shorten "${D}"/usr/share/man/man1/shorten.1 || die
+}