summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-07 23:18:31 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-07 23:18:31 +0000
commit375507147b4f58458fc077215b8e30f7811851eb (patch)
treea46ba694db40727f5897ab4d48d3784c1f28ae0e /dev-php/php
parentbug #32962, new version (diff)
downloadgentoo-2-375507147b4f58458fc077215b8e30f7811851eb.tar.gz
gentoo-2-375507147b4f58458fc077215b8e30f7811851eb.tar.bz2
gentoo-2-375507147b4f58458fc077215b8e30f7811851eb.zip
bug #32962, new version
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-4.3.43
-rw-r--r--dev-php/php/php-4.3.4.ebuild50
4 files changed, 61 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 9815ba6a3529..4effa282fd53 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.63 2003/10/26 04:16:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.64 2003/11/07 23:18:29 robbat2 Exp $
+
+*php-4.3.4 (07 Nov 2003)
+
+ 07 Nov 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.4.ebuild:
+ bug #32962, new version
25 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> php-5.0_beta1-r1.ebuild:
fix bug #25326 hopefully
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index bbd9e249a2bb..b58580727b1b 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -3,10 +3,10 @@ MD5 0d9585a857a06f4d336cf647dd8728d4 php-4.3.2-r3.ebuild 1140
MD5 c8cc2dc8ab39618308726f1749d14d61 php-4.3.3-r2.ebuild 1207
MD5 25f97fc9df6d134f3da1b4e5c1414830 php-4.3.2.ebuild 2418
MD5 3eeafc4e390ffd783e014a5ec877e820 php-4.3.2-r2.ebuild 1182
-MD5 bc498859e45cdd2924f64ae5ef806239 php-4.3.4.ebuild 1210
+MD5 916c5f3be4284c778802477371649523 php-4.3.4.ebuild 1209
MD5 f1385520cac897796eeae1ad974ac15c php-4.3.3-r1.ebuild 1208
MD5 ff00712ef064fedea5c310204c367b1a php-5.0_beta1.ebuild 1176
-MD5 9751be17197a00183a15d02ff78ebe8a ChangeLog 9667
+MD5 bb50635b261c01209a6c9591355afd1c ChangeLog 9791
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 db16022e0ec00d919b30ab222f073577 php-4.3.3-r3.ebuild 1218
MD5 ce0950f7facac1bcd6c3f99321f4648a php-4.3.2-r1.ebuild 990
diff --git a/dev-php/php/files/digest-php-4.3.4 b/dev-php/php/files/digest-php-4.3.4
new file mode 100644
index 000000000000..2f7602289366
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.4
@@ -0,0 +1,3 @@
+MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
+MD5 a5dd907ca0aed4ba38c79181d407cbff php-4.3.4-phpizeexecfix.patch 386
diff --git a/dev-php/php/php-4.3.4.ebuild b/dev-php/php/php-4.3.4.ebuild
new file mode 100644
index 000000000000..4ca62562acaa
--- /dev/null
+++ b/dev-php/php/php-4.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.4.ebuild,v 1.1 2003/11/07 23:18:29 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ # Readline and Ncurses are CLI PHP only
+ # readline implies ncurses
+ use ncurses || use readline && use_ncurses="--with-" || use_ncurses="--without-"
+ myconf="${myconf} `use_with readline`"
+ myconf="${myconf} ${use_ncurses}-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}