summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-03-29 15:45:00 +0000
committerStuart Herbert <stuart@gentoo.org>2004-03-29 15:45:00 +0000
commitc727fcfaa53a475e1e6a15175e8fd13a9f195ddd (patch)
tree31b9c78318890b3b6656f8fadd9bd12153740052 /dev-php/phpsysinfo
parentstable on ppc (Manifest recommit) (diff)
downloadgentoo-2-c727fcfaa53a475e1e6a15175e8fd13a9f195ddd.tar.gz
gentoo-2-c727fcfaa53a475e1e6a15175e8fd13a9f195ddd.tar.bz2
gentoo-2-c727fcfaa53a475e1e6a15175e8fd13a9f195ddd.zip
Reduced screen output
Diffstat (limited to 'dev-php/phpsysinfo')
-rw-r--r--dev-php/phpsysinfo/ChangeLog5
-rw-r--r--dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-php/phpsysinfo/ChangeLog b/dev-php/phpsysinfo/ChangeLog
index de32c2b8078e..cab566335b56 100644
--- a/dev-php/phpsysinfo/ChangeLog
+++ b/dev-php/phpsysinfo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/phpsysinfo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/ChangeLog,v 1.12 2004/03/29 12:29:46 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/ChangeLog,v 1.13 2004/03/29 15:45:00 stuart Exp $
+
+ 29 Mar 2004; Stuart Herbert <stuart@gentoo.org> phpsysinfo-2.1-r2.ebuild:
+ Reduced output to the screen when deciding to apply the kernel patch
29 Mar 2004; Sven Blumenstein <bazik@gentoo.org> phpsysinfo-2.1-r2.ebuild:
Stable on sparc and applied fix from bug #46081. Will fix CPU info for sparc
diff --git a/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild b/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
index 9e1a2f539220..5b4fbf3ba7b7 100644
--- a/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
+++ b/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild,v 1.3 2004/03/29 12:29:46 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild,v 1.4 2004/03/29 15:45:00 stuart Exp $
inherit eutils kernel-mod
@@ -20,10 +20,6 @@ DEPEND=">=net-www/apache-1.3.27-r1
S=${WORKDIR}/${MY_P}
-src_compile() {
- echo "Nothing to do."
-}
-
src_unpack() {
unpack ${MY_P}.tar.gz
epatch ${DISTDIR}/${PN}_${PV}-1.diff.gz
@@ -31,12 +27,17 @@ src_unpack() {
rmdir ${P}
epatch ${S}/debian/patches/urlencoded-security-fix.diff
- APPLY_25PATCH=0
- kernel-mod_is_2_5_kernel && APPLY_25PATCH=1
- kernel-mod_is_2_6_kernel && APPLY_25PATCH=1
+ APPLY_25PATCH=-1
+ kernel-mod_is_2_4_kernel && APPLY_25PATCH=0
+ [ "APPLY_25PATCH" = "-1" ] && kernel-mod_is_2_5_kernel && APPLY_25PATCH=1
+ [ "APPLY_25PATCH" = "-1" ] && kernel-mod_is_2_6_kernel && APPLY_25PATCH=1
[ "$APPLY_25PATCH" = "1" ] && epatch ${FILESDIR}/fix_memory_display_kernel2.5.diff.gz
}
+src_compile() {
+ einfo "Nothing to compile"
+}
+
src_install() {
HTDOCS="/var/www/localhost/htdocs"
insinto ${HTDOCS}/phpsysinfo