summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-11-03 22:11:40 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-11-03 22:11:40 +0000
commitea75a52d326ce04cf77f1b71701d3682456260e1 (patch)
treeb000a308d3830653f4fe85d055f329501a8f4041 /dev-php5/eaccelerator
parentVersion bump. (diff)
downloadgentoo-2-ea75a52d326ce04cf77f1b71701d3682456260e1.tar.gz
gentoo-2-ea75a52d326ce04cf77f1b71701d3682456260e1.tar.bz2
gentoo-2-ea75a52d326ce04cf77f1b71701d3682456260e1.zip
Added a version that supports minor version slotting
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/eaccelerator')
-rw-r--r--dev-php5/eaccelerator/ChangeLog7
-rw-r--r--dev-php5/eaccelerator/eaccelerator-0.9.6.1-r1.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-php5/eaccelerator/ChangeLog b/dev-php5/eaccelerator/ChangeLog
index b41c3d7abe23..fcee5e469413 100644
--- a/dev-php5/eaccelerator/ChangeLog
+++ b/dev-php5/eaccelerator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/eaccelerator
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.26 2010/10/23 08:25:41 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.27 2010/11/03 22:11:40 olemarkus Exp $
+
+*eaccelerator-0.9.6.1-r1 (03 Nov 2010)
+
+ 03 Nov 2010; <olemarkus@gentoo.org> +eaccelerator-0.9.6.1-r1.ebuild:
+ Added a version that supports minor version slotting
23 Oct 2010; <olemarkus@gentoo.org> eaccelerator-0.9.6.1.ebuild:
Swapped depending on specific httpd SAPI's with virtual/httpd-php. Thanks to Andrey Yurchuk for notifying
diff --git a/dev-php5/eaccelerator/eaccelerator-0.9.6.1-r1.ebuild b/dev-php5/eaccelerator/eaccelerator-0.9.6.1-r1.ebuild
new file mode 100644
index 000000000000..b8c3355742e4
--- /dev/null
+++ b/dev-php5/eaccelerator/eaccelerator-0.9.6.1-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/eaccelerator-0.9.6.1-r1.ebuild,v 1.1 2010/11/03 22:11:40 olemarkus Exp $
+
+PHP_EXT_NAME="eaccelerator"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+EAPI="2"
+
+[[ -z "${EACCELERATOR_CACHEDIR}" ]] && EACCELERATOR_CACHEDIR="/var/cache/eaccelerator-php5/"
+
+inherit php-ext-source-r2 eutils depend.apache
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A PHP Accelerator & Encoder."
+HOMEPAGE="http://www.eaccelerator.net/"
+SRC_URI="http://bart.eaccelerator.net/source/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug disassembler inode doccommentinclusion session"
+
+DEPEND="!dev-php5/pecl-apc !dev-php5/xcache"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.1[zlib,session?]
+ virtual/httpd-php
+"
+
+# Webserver user and group, here for Apache by default
+HTTPD_USER="${HTTPD_USER:-apache}"
+HTTPD_GROUP="${HTTPD_GROUP:-apache}"
+
+want_apache
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ if ! use apache2 ; then
+ if [[ ${HTTPD_USER} == "apache" ]] || [[ ${HTTPD_GROUP} == "apache" ]] ; then
+ eerror "You did not enable apache2 USE flag, so you need to define"
+ eerror "the user and group that will be used for ${PN} yourself."
+ eerror
+ eerror "This should (generally) match the user and group that your webserver uses, e.g.:"
+ eerror "HTTPD_USER=\"lighttpd\" HTTPD_GROUP=\"lighttpd\" if using www-servers/lighttpd"
+ eerror
+ die "Either enable USE=\"apache2\" or re-emerge this with HTTPD_USER and HTTPD_GROUP set"
+ else
+ enewgroup ${HTTPD_GROUP}
+ enewuser ${HTTPD_USER} -1 -1 /var/www ${HTTPD_GROUP}
+ fi
+ fi
+}
+
+src_compile() {
+ my_conf="--enable-eaccelerator=shared --with-eaccelerator-userid=`id -u ${HTTPD_USER}`"
+ use debug && my_conf="${my_conf} --with-eaccelerator-debug"
+ use disassembler && my_conf="${my_conf} --with-eaccelerator-disassembler"
+ ! use inode && my_conf="${my_conf} --without-eaccelerator-use-inode"
+ use doccommentinclusion && my_conf="${my_conf} --with-eaccelerator-doc-comment-inclusion"
+ php-ext-source-r2_src_compile
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+
+ keepdir "${EACCELERATOR_CACHEDIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${EACCELERATOR_CACHEDIR}"
+ fperms 750 "${EACCELERATOR_CACHEDIR}"
+
+ insinto "/usr/share/${PVR}"
+ doins -r doc/php/
+ dodoc AUTHORS ChangeLog NEWS README
+
+ php-ext-source-r2_addtoinifiles "eaccelerator.shm_size" '"28"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.cache_dir" "\"${EACCELERATOR_CACHEDIR}\""
+ php-ext-source-r2_addtoinifiles "eaccelerator.enable" '"1"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.optimizer" '"1"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.debug" '"0"'
+ php-ext-source-r2_addtoinifiles ";eaccelerator.log_file" '"/var/log/eaccelerator_log"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.check_mtime" '"1"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.filter" '""'
+ php-ext-source-r2_addtoinifiles "eaccelerator.shm_ttl" '"0"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.shm_prune_period" '"0"'
+ php-ext-source-r2_addtoinifiles "eaccelerator.shm_only" '"0"'
+ php-ext-source-r2_addtoinifiles ";eaccelerator.allowed_admin_path" '"/path/where/admin/files/shall/be/allowed"'
+}
+
+pkg_postinst() {
+ elog "Please see the files in ${ROOT}usr/share/${PVR}/ for some"
+ elog "examples and informations on how to use the functions that"
+ elog "eAccelerator adds to PHP."
+}