summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2008-11-23 18:02:08 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2008-11-23 18:02:08 +0000
commit2944304d9ce354b11a72622d5210702311ede2bd (patch)
treede1eaef8ca081da92983d2422246566b65b11dee /dev-php5
parentadded possibility to gzip .idx files (diff)
downloadgentoo-2-2944304d9ce354b11a72622d5210702311ede2bd.tar.gz
gentoo-2-2944304d9ce354b11a72622d5210702311ede2bd.tar.bz2
gentoo-2-2944304d9ce354b11a72622d5210702311ede2bd.zip
Bumping to 1.7.0
(Portage version: 2.2_rc15/cvs/Linux 2.6.27 i686)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/ZendFramework/ChangeLog8
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.7.0.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index 900b497cc935..6ef353e27097 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/ZendFramework
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.33 2008/09/03 22:05:40 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.34 2008/11/23 18:02:08 gurligebis Exp $
+
+*ZendFramework-1.7.0 (23 Nov 2008)
+
+ 23 Nov 2008; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ +ZendFramework-1.7.0.ebuild:
+ Bumping to 1.7.0
*ZendFramework-1.6.0 (04 Sep 2008)
diff --git a/dev-php5/ZendFramework/ZendFramework-1.7.0.ebuild b/dev-php5/ZendFramework/ZendFramework-1.7.0.ebuild
new file mode 100644
index 000000000000..9ecada45e338
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.7.0.ebuild,v 1.1 2008/11/23 18:02:08 gurligebis Exp $
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal"
+
+DEPEND=""
+RDEPEND=""
+need_php_by_category
+
+src_unpack() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ fi
+
+ unpack ${A}
+
+ cd "${S}"
+}
+
+src_install() {
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests has not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includde the Dojo toolkit, demos and tests."
+ elog "To install without there, enable the minimal USE flag"
+ fi
+}