summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2008-05-02 16:37:03 +0000
committerLuca Longinotti <chtekk@gentoo.org>2008-05-02 16:37:03 +0000
commit92e4378d5dfbe62e6ed723185c393ba022c797dd (patch)
tree26ce0dd25e279e535aa6163587b584457376b6f5 /dev-php5
parentFix QA bug #218657. (diff)
downloadgentoo-2-92e4378d5dfbe62e6ed723185c393ba022c797dd.tar.gz
gentoo-2-92e4378d5dfbe62e6ed723185c393ba022c797dd.tar.bz2
gentoo-2-92e4378d5dfbe62e6ed723185c393ba022c797dd.zip
Add missing patch.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/php-qt/ChangeLog6
-rw-r--r--dev-php5/php-qt/files/php-qt-0.9-no-qwt.patch32
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-php5/php-qt/ChangeLog b/dev-php5/php-qt/ChangeLog
index 59122080b853..d866c69a9f56 100644
--- a/dev-php5/php-qt/ChangeLog
+++ b/dev-php5/php-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/php-qt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-qt/ChangeLog,v 1.11 2008/05/02 16:22:07 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-qt/ChangeLog,v 1.12 2008/05/02 16:37:02 chtekk Exp $
+
+ 02 May 2008; Luca Longinotti <chtekk@gentoo.org>
+ +files/php-qt-0.9-no-qwt.patch:
+ Add missing patch.
02 May 2008; Luca Longinotti <chtekk@gentoo.org> php-qt-0.9.ebuild:
Fix QA bug #218657.
diff --git a/dev-php5/php-qt/files/php-qt-0.9-no-qwt.patch b/dev-php5/php-qt/files/php-qt-0.9-no-qwt.patch
new file mode 100644
index 000000000000..caf41fbc315c
--- /dev/null
+++ b/dev-php5/php-qt/files/php-qt-0.9-no-qwt.patch
@@ -0,0 +1,32 @@
+--- smoke/qt/CMakeLists.txt.old 2008-02-07 11:31:55.000000000 +0100
++++ smoke/qt/CMakeLists.txt 2008-02-07 11:32:08.000000000 +0100
+@@ -1,6 +1,6 @@
+
+ include(FindQScintilla)
+-include(FindQwt5)
++#include(FindQwt5)
+
+ include_directories( ${QT_INCLUDES} ${CMAKE_CURRENT_SOURCE_DIR}/../ )
+
+@@ -13,13 +13,13 @@
+ message(STATUS "QScintilla not found, support disabled")
+ endif(QSCINTILLA_FOUND)
+
+-if(Qwt5_Qt4_FOUND)
+- message(STATUS "Including Qwt5 support into smokeqt")
+- include_directories( ${Qwt5_INCLUDE_DIR} )
+- set(_smokeqt_optional_libs ${_smokeqt_optional_libs} ${Qwt5_Qt4_LIBRARY})
+-else(Qwt5_Qt4_FOUND)
+- message(STATUS "Qwt5 not found, support disabled")
+-endif(Qwt5_Qt4_FOUND)
++#if(Qwt5_Qt4_FOUND)
++# message(STATUS "Including Qwt5 support into smokeqt")
++# include_directories( ${Qwt5_INCLUDE_DIR} )
++# set(_smokeqt_optional_libs ${_smokeqt_optional_libs} ${Qwt5_Qt4_LIBRARY})
++#else(Qwt5_Qt4_FOUND)
++# message(STATUS "Qwt5 not found, support disabled")
++#endif(Qwt5_Qt4_FOUND)
+
+ IF(NOT PERL_FOUND)
+ FIND_PACKAGE(PERL REQUIRED)
+