summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-11-19 18:16:52 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-11-19 18:16:52 +0000
commitd2cc738ad4183a92f4fc85182df7a55619dda840 (patch)
treeb5494543608a24efec701a19b1d7b2be5489daa4 /dev-php5
parentInitial ebuild. (diff)
downloadgentoo-2-d2cc738ad4183a92f4fc85182df7a55619dda840.tar.gz
gentoo-2-d2cc738ad4183a92f4fc85182df7a55619dda840.tar.bz2
gentoo-2-d2cc738ad4183a92f4fc85182df7a55619dda840.zip
Version bump.
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/phpunit/ChangeLog8
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.0.03
-rw-r--r--dev-php5/phpunit/phpunit-3.0.0.ebuild26
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 91675d49b24c..f33826e3abf1 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.1 2006/09/08 08:26:30 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.2 2006/11/19 18:16:52 sebastian Exp $
+
+*phpunit-3.0.0 (19 Nov 2006)
+
+ 19 Nov 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ +phpunit-3.0.0.ebuild:
+ Version bump.
*phpunit-2.3.6 (08 Sep 2006)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.0.0 b/dev-php5/phpunit/files/digest-phpunit-3.0.0
new file mode 100644
index 000000000000..cab030cb8f90
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.0.0
@@ -0,0 +1,3 @@
+MD5 78b6e3b310acf8fdb569adf0ea29a3e1 PHPUnit-3.0.0.tgz 100207
+RMD160 222de7946df55e6a26f4bc29551e6a061ecfe52a PHPUnit-3.0.0.tgz 100207
+SHA256 d8f12c5e48ea76a8ef021d0691addc944c38dee2aa130ffe5d885bedb206bae5 PHPUnit-3.0.0.tgz 100207
diff --git a/dev-php5/phpunit/phpunit-3.0.0.ebuild b/dev-php5/phpunit/phpunit-3.0.0.ebuild
new file mode 100644
index 000000000000..3deea1792481
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.0.0.ebuild,v 1.1 2006/11/19 18:16:52 sebastian Exp $
+
+inherit php-pear-lib-r1
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="!dev-php4/phpunit"
+RDEPEND=">=dev-lang/php-5.1.4
+ >=dev-php5/xdebug-2.0.0_rc1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Testing_Selenium-0.2.1"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+S="${WORKDIR}/PHPUnit-${PV}"
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml
+}
+
+need_php_by_category