summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-12-31 00:16:21 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-12-31 00:16:21 +0000
commit40832ac54aec53431a9b0d521500186f9a2d7f6f (patch)
tree4f7a92f4206afe347b740aaa6787be662ed68a17 /dev-php
parentStable on sparc, bug #248458 (diff)
downloadgentoo-2-40832ac54aec53431a9b0d521500186f9a2d7f6f.tar.gz
gentoo-2-40832ac54aec53431a9b0d521500186f9a2d7f6f.tar.bz2
gentoo-2-40832ac54aec53431a9b0d521500186f9a2d7f6f.zip
bump
(Portage version: 2.1.6.2/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/roadsend-php/ChangeLog8
-rw-r--r--dev-php/roadsend-php/roadsend-php-2.9.8.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-php/roadsend-php/ChangeLog b/dev-php/roadsend-php/ChangeLog
index dce93790c85a..74586add51fa 100644
--- a/dev-php/roadsend-php/ChangeLog
+++ b/dev-php/roadsend-php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/roadsend-php
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.9 2008/11/17 20:55:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.10 2008/12/31 00:16:21 hkbst Exp $
+
+*roadsend-php-2.9.8 (31 Dec 2008)
+
+ 31 Dec 2008; Marijn Schouten <hkBst@gentoo.org>
+ +roadsend-php-2.9.8.ebuild:
+ bump
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/bigloo-3.1a-configsupport.patch:
diff --git a/dev-php/roadsend-php/roadsend-php-2.9.8.ebuild b/dev-php/roadsend-php/roadsend-php-2.9.8.ebuild
new file mode 100644
index 000000000000..996eb9a0a9b0
--- /dev/null
+++ b/dev-php/roadsend-php/roadsend-php-2.9.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/roadsend-php-2.9.8.ebuild,v 1.1 2008/12/31 00:16:21 hkbst Exp $
+
+inherit eutils
+
+MY_PVL=${PV/_p/-r}
+MY_PV=${PV%%_p[0-9]}
+MY_PL=${PN}-${MY_PVL}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Roadsend PHP compiler"
+HOMEPAGE="http://code.roadsend.com/pcc"
+SRC_URI="http://code.roadsend.com/snaps/${MY_PL}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.0c
+ >=net-misc/curl-7.15.1-r1
+ mysql? ( dev-db/mysql )
+ sqlite3? ( >=dev-db/sqlite-3.3.12 )
+ pcre? ( >=dev-libs/libpcre-6.6 )
+ xml? ( dev-libs/libxml2 )
+ odbc? ( dev-db/unixODBC )
+ fastcgi? ( dev-libs/fcgi )"
+
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+IUSE="debug fastcgi mysql odbc pcre sqlite3 xml"
+#IUSE="fastcgi mysql odbc pcre sqlite3 xml"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_with pcre) $(use_with fastcgi fcgi) $(use_with xml) $(use_with mysql) $(use_with sqlite3) $(use_with odbc)
+
+ if use debug; then
+ emake -j1 debug || die "make debug failed"
+ else
+ emake -j1 || die "make failed"
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/libs/" emake -j1 test || die "standalone tests failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+}