summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-02-02 12:16:08 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-02-02 12:16:08 +0000
commitc45eae797c8137f82c22b5edded05601b07b820f (patch)
tree84487bf9a3c8842e31cd99d86f2ee28774f631e7 /dev-php
parentAdd missing module and remove * from tilde query (diff)
downloadgentoo-2-c45eae797c8137f82c22b5edded05601b07b820f.tar.gz
gentoo-2-c45eae797c8137f82c22b5edded05601b07b820f.tar.bz2
gentoo-2-c45eae797c8137f82c22b5edded05601b07b820f.zip
Version/EAPI/USE_PHP bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-haru/ChangeLog9
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.3.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-php/pecl-haru/ChangeLog b/dev-php/pecl-haru/ChangeLog
index 7319cb4adab8..defc2007eac1 100644
--- a/dev-php/pecl-haru/ChangeLog
+++ b/dev-php/pecl-haru/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-haru
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.1 2011/12/14 22:37:15 mabi Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.2 2012/02/02 12:16:08 olemarkus Exp $
+
+*pecl-haru-1.0.3 (02 Feb 2012)
+
+ 02 Feb 2012; Ole Markus With <olemarkus@gentoo.org> +pecl-haru-1.0.3.ebuild:
+ Version/EAPI/USE_PHP bump
*pecl-haru-1.0.0-r1 (04 Nov 2010)
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.3.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.3.ebuild
new file mode 100644
index 000000000000..fa41337cc532
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/pecl-haru-1.0.3.ebuild,v 1.1 2012/02/02 12:16:08 olemarkus Exp $
+
+EAPI=4
+
+PHP_EXT_NAME="haru"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf="--with-haru=/usr"
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}