summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Shoemaker <kutsuya@gentoo.org>2003-03-06 03:00:37 +0000
committerJason Shoemaker <kutsuya@gentoo.org>2003-03-06 03:00:37 +0000
commitc415e0ccc519e432f3d7a3bdf44b0b42c5eb348c (patch)
treebe25a93bde7943ca7da58a4bf0691c11655b0e15 /dev-python/Imaging
parenttstr shoudl have been tmpstr. Fixed. (diff)
downloadgentoo-2-c415e0ccc519e432f3d7a3bdf44b0b42c5eb348c.tar.gz
gentoo-2-c415e0ccc519e432f3d7a3bdf44b0b42c5eb348c.tar.bz2
gentoo-2-c415e0ccc519e432f3d7a3bdf44b0b42c5eb348c.zip
Major revision. Now using distutils.eclass, so removed all but ~x86 arch.
Diffstat (limited to 'dev-python/Imaging')
-rw-r--r--dev-python/Imaging/ChangeLog12
-rw-r--r--dev-python/Imaging/Imaging-1.1.3-r1.ebuild50
-rw-r--r--dev-python/Imaging/files/digest-Imaging-1.1.3-r11
3 files changed, 60 insertions, 3 deletions
diff --git a/dev-python/Imaging/ChangeLog b/dev-python/Imaging/ChangeLog
index d37e487c32ba..5398ac9167ad 100644
--- a/dev-python/Imaging/ChangeLog
+++ b/dev-python/Imaging/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for dev-python/Imaging
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/ChangeLog,v 1.7 2003/02/12 06:30:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/ChangeLog,v 1.8 2003/03/06 03:00:37 kutsuya Exp $
+
+*Imaging-1.1.3-r1 (05 Mar 2003)
+
+ 05 Mar 2003; Jason Shoemaker <kutsuya@gentoo.org> Imaging-1.1.3-r1.ebuild:
+ Modified to take advantage of distutils.eclass. Removed all but ~x86 arch,
+ because of the major revision.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*Imaging-1.1.3 (3 Nov 2002)
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
3 Nov 2002; Nicholas Henke <roughneck@gentoo.org> Imaging-1.1.3.ebuild :
Bumped version to 1.1.3.
diff --git a/dev-python/Imaging/Imaging-1.1.3-r1.ebuild b/dev-python/Imaging/Imaging-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..6454c8ba1bdf
--- /dev/null
+++ b/dev-python/Imaging/Imaging-1.1.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.3-r1.ebuild,v 1.1 2003/03/06 03:00:37 kutsuya Exp $
+
+inherit distutils
+
+IUSE="tcltk"
+
+DESCRIPTION="Python Imaging Library (PIL)."
+SRC_URI="http://www.pythonware.com/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.pythonware.com/downloads/#pil"
+
+DEPEND=">=media-libs/jpeg-6a
+ >=sys-libs/zlib-0.95
+ tcltk? ( dev-lang/tk )"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="as-is"
+
+ src_compile() {
+ export OPT=${CFLAGS}
+
+ #Build the core imaging library (libImaging.a)
+ cd ${S}/libImaging
+ econf
+ cp Makefile Makefile.orig
+
+ #Not configured by configure
+ sed \
+ -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ Makefile.orig > Makefile
+ emake || die
+ cd ${S}
+ distutils_src_compile
+}
+
+src_install ()
+{
+ local mydoc="CHANGES* CONTENTS"
+ distutils_src_install
+ distutils_python_version
+
+ # install headers required by media-gfx/sketch
+ insinto "${ROOT}/usr/include/python${PYVER}"
+ doins libImaging/Imaging.h
+ doins libImaging/ImPlatform.h
+ doins libImaging/ImConfig.h
+}
+
diff --git a/dev-python/Imaging/files/digest-Imaging-1.1.3-r1 b/dev-python/Imaging/files/digest-Imaging-1.1.3-r1
new file mode 100644
index 000000000000..9f6f98af43e5
--- /dev/null
+++ b/dev-python/Imaging/files/digest-Imaging-1.1.3-r1
@@ -0,0 +1 @@
+MD5 563471981376e06b3278ad713a07e2a8 Imaging-1.1.3.tar.gz 346194