summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-05 14:16:50 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-05 14:16:50 +0000
commited0d92ffceaabdccca08379b5593b48c6c660456 (patch)
tree27ae076907f1296124874228f1d09c5f561b342d /dev-python/anyjson
parentDrop stale conditionals after py2.5 removal. (diff)
downloadgentoo-2-ed0d92ffceaabdccca08379b5593b48c6c660456.tar.gz
gentoo-2-ed0d92ffceaabdccca08379b5593b48c6c660456.tar.bz2
gentoo-2-ed0d92ffceaabdccca08379b5593b48c6c660456.zip
Drop stale conditionals after py2.5 removal.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/anyjson')
-rw-r--r--dev-python/anyjson/ChangeLog6
-rw-r--r--dev-python/anyjson/anyjson-0.2.4.ebuild10
-rw-r--r--dev-python/anyjson/anyjson-0.3.3-r1.ebuild10
3 files changed, 9 insertions, 17 deletions
diff --git a/dev-python/anyjson/ChangeLog b/dev-python/anyjson/ChangeLog
index ee9f4ed8d7e7..74852dfaeeab 100644
--- a/dev-python/anyjson/ChangeLog
+++ b/dev-python/anyjson/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/anyjson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/ChangeLog,v 1.8 2013/03/30 12:58:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/ChangeLog,v 1.9 2013/09/05 14:16:50 mgorny Exp $
+
+ 05 Sep 2013; Michał Górny <mgorny@gentoo.org> anyjson-0.2.4.ebuild,
+ anyjson-0.3.3-r1.ebuild:
+ Drop stale conditionals after py2.5 removal.
30 Mar 2013; Mike Gilbert <floppym@gentoo.org> anyjson-0.2.4.ebuild,
anyjson-0.3.3-r1.ebuild:
diff --git a/dev-python/anyjson/anyjson-0.2.4.ebuild b/dev-python/anyjson/anyjson-0.2.4.ebuild
index b158f9945a26..274e63476a36 100644
--- a/dev-python/anyjson/anyjson-0.2.4.ebuild
+++ b/dev-python/anyjson/anyjson-0.2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/anyjson-0.2.4.ebuild,v 1.2 2013/03/30 12:58:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/anyjson-0.2.4.ebuild,v 1.3 2013/09/05 14:16:50 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
inherit distutils-r1
@@ -17,12 +17,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-# python2.6+ has builtin json module
-# python2.5 needs any of the supported impls
-RDEPEND="
- python_targets_python2_5? (
- dev-python/simplejson[python_targets_python2_5] )"
-
# please keep all supported implementations in 'test?'
# to make sure the package is used in the widest way
DEPEND="${RDEPEND}
diff --git a/dev-python/anyjson/anyjson-0.3.3-r1.ebuild b/dev-python/anyjson/anyjson-0.3.3-r1.ebuild
index cf1b030f1394..253ea9fec1a0 100644
--- a/dev-python/anyjson/anyjson-0.3.3-r1.ebuild
+++ b/dev-python/anyjson/anyjson-0.3.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/anyjson-0.3.3-r1.ebuild,v 1.3 2013/03/30 12:58:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyjson/anyjson-0.3.3-r1.ebuild,v 1.4 2013/09/05 14:16:50 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
inherit distutils-r1
@@ -17,12 +17,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-# python2.6+ has builtin json module
-# python2.5 needs any of the supported impls
-RDEPEND="
- python_targets_python2_5? (
- dev-python/simplejson[python_targets_python2_5] )"
-
# please keep all supported implementations in 'test?'
# to make sure the package is used in the widest way
DEPEND="${RDEPEND}