summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 21:17:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 21:17:21 +0000
commit5b0033139d39b0a9d5a8ee68867a9b7d2e77cfbc (patch)
tree0f23b900acb820cd94fee7bd7cc67fe30b6d2d63 /dev-python/asciitable
parentVersion bump. Translation updates. Update API use. (diff)
downloadgentoo-2-5b0033139d39b0a9d5a8ee68867a9b7d2e77cfbc.tar.gz
gentoo-2-5b0033139d39b0a9d5a8ee68867a9b7d2e77cfbc.tar.bz2
gentoo-2-5b0033139d39b0a9d5a8ee68867a9b7d2e77cfbc.zip
Disable tests with Python 3.
(Portage version: 2.2_rc88_p40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/asciitable')
-rw-r--r--dev-python/asciitable/ChangeLog6
-rw-r--r--dev-python/asciitable/asciitable-0.3.1.ebuild20
2 files changed, 18 insertions, 8 deletions
diff --git a/dev-python/asciitable/ChangeLog b/dev-python/asciitable/ChangeLog
index 4fde3aa1c66f..385b22648576 100644
--- a/dev-python/asciitable/ChangeLog
+++ b/dev-python/asciitable/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/asciitable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/ChangeLog,v 1.3 2010/09/29 05:56:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/ChangeLog,v 1.4 2010/09/29 21:17:21 arfrever Exp $
+
+ 29 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ asciitable-0.3.1.ebuild:
+ Disable tests with Python 3.
*asciitable-0.3.1 (29 Sep 2010)
diff --git a/dev-python/asciitable/asciitable-0.3.1.ebuild b/dev-python/asciitable/asciitable-0.3.1.ebuild
index c2505aded96b..8d7689805dd0 100644
--- a/dev-python/asciitable/asciitable-0.3.1.ebuild
+++ b/dev-python/asciitable/asciitable-0.3.1.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/asciitable-0.3.1.ebuild,v 1.1 2010/09/29 05:56:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/asciitable-0.3.1.ebuild,v 1.2 2010/09/29 21:17:21 arfrever Exp $
EAPI="3"
-#PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-#RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -17,9 +14,18 @@ SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/numpy"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
PYTHON_MODNAME="asciitable.py"
+
+src_test() {
+ testing() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests
+ }
+ python_execute_function testing
+}