summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 00:50:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 00:50:40 +0000
commit2b6a703e66e741c18649d1d71ba53da9bc8eceee (patch)
tree954d24f060909bed191dc0de508ed152912b7b11 /dev-python/astng/astng-0.20.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-2b6a703e66e741c18649d1d71ba53da9bc8eceee.tar.gz
gentoo-2-2b6a703e66e741c18649d1d71ba53da9bc8eceee.tar.bz2
gentoo-2-2b6a703e66e741c18649d1d71ba53da9bc8eceee.zip
Version bump.
(Portage version: 2.2_rc88_p32/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/astng/astng-0.20.3.ebuild')
-rw-r--r--dev-python/astng/astng-0.20.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/astng/astng-0.20.3.ebuild b/dev-python/astng/astng-0.20.3.ebuild
new file mode 100644
index 000000000000..51ec7d0f9d2f
--- /dev/null
+++ b/dev-python/astng/astng-0.20.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.3.ebuild,v 1.1 2010/09/29 00:50:40 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+HOMEPAGE="http://www.logilab.org/projects/astng/ http://pypi.python.org/pypi/logilab-astng"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz mirror://pypi/l/logilab-astng/logilab-${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.49.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( >=dev-python/egenix-mx-base-3.0.0 )"
+
+S="${WORKDIR}/logilab-${P}"
+
+PYTHON_MODNAME="logilab/astng"
+
+src_test() {
+ testing() {
+ local tpath="${T}/test-${PYTHON_ABI}"
+ local spath="${tpath}$(python_get_sitedir)"
+
+ mkdir -p "${spath}/logilab" || return 1
+ cp -r "$(python_get_sitedir)/logilab/common" "${spath}/logilab" || return 1
+
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
+
+ # pytest uses tests placed relatively to the current directory.
+ pushd "${spath}/logilab/astng" > /dev/null || return 1
+ PYTHONPATH="${spath}" pytest -v || return 1
+ popd > /dev/null || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ deletion_of_unneeded_files() {
+ # Avoid collision with dev-python/logilab-common.
+ rm -f "${ED}$(python_get_sitedir)/logilab/__init__.py" || return 1
+
+ # Don't install tests.
+ rm -fr "${ED}$(python_get_sitedir)/logilab/astng/test" || return 1
+ }
+ python_execute_function -q deletion_of_unneeded_files
+}