summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-28 07:10:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-28 07:10:07 +0000
commit7999e2159a9bdbe6b158f1bcd374694c97e6e18e (patch)
tree0cc7d3f9e1f1fbf1dc325cf36621768f53e575b3 /dev-python/autopep8
parentpython-keystoneclient bup (diff)
downloadgentoo-2-7999e2159a9bdbe6b158f1bcd374694c97e6e18e.tar.gz
gentoo-2-7999e2159a9bdbe6b158f1bcd374694c97e6e18e.tar.bz2
gentoo-2-7999e2159a9bdbe6b158f1bcd374694c97e6e18e.zip
Bump
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog9
-rw-r--r--dev-python/autopep8/autopep8-1.1.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 70539cace056..ffaf7d850036 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.54 2014/12/27 19:36:01 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.55 2015/02/28 07:10:07 patrick Exp $
+
+*autopep8-1.1.1 (28 Feb 2015)
+
+ 28 Feb 2015; Patrick Lauer <patrick@gentoo.org> +autopep8-1.1.1.ebuild:
+ Bump
27 Dec 2014; Agostino Sarubbo <ago@gentoo.org> autopep8-1.0.4.ebuild:
Stable for amd64, wrt bug #502772
diff --git a/dev-python/autopep8/autopep8-1.1.1.ebuild b/dev-python/autopep8/autopep8-1.1.1.ebuild
new file mode 100644
index 000000000000..3e58c7e06bb4
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.1.1.ebuild,v 1.1 2015/02/28 07:10:07 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+ # from the tox.ini
+ "${PYTHON}" test/acid.py --aggressive test/example.py || die
+ "${PYTHON}" test/acid.py --compare-bytecode test/example.py || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}