summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-23 18:06:55 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-23 18:06:55 +0000
commita903f8b55886ba54753ee14828477b4e5b58f1d3 (patch)
treea3a4d68c11d797dd209ab01cb8d6c47e7e2f60b5 /dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild
parentAdd ~amd64 keyword. (diff)
downloadgentoo-2-a903f8b55886ba54753ee14828477b4e5b58f1d3.tar.gz
gentoo-2-a903f8b55886ba54753ee14828477b4e5b58f1d3.tar.bz2
gentoo-2-a903f8b55886ba54753ee14828477b4e5b58f1d3.zip
Version bump (bug #197293).
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild
new file mode 100644
index 000000000000..8b628d010dc6
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.5.ebuild,v 1.1 2008/02/23 18:06:55 dev-zero Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils
+
+MY_P=BeautifulSoup-${PV}
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
+SRC_URI="http://www.crummy.com/software/BeautifulSoup/download/${MY_P}.tar.gz"
+LICENSE="PSF-2.3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ PYTHONPATH="." "${python}" BeautifulSoupTests.py || die "tests failed"
+}