summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-01 08:06:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-01 08:06:02 +0000
commit1d1bcb769d8ace2e0fac9c1fe9a5df7247414130 (patch)
tree26422b4e50eacf8442a521fadf3dc69d9d8e6fea /dev-python/beautifulsoup
parentBackport gcc-4.9 and Athlon fixes from 1.0.0 (diff)
downloadgentoo-2-1d1bcb769d8ace2e0fac9c1fe9a5df7247414130.tar.gz
gentoo-2-1d1bcb769d8ace2e0fac9c1fe9a5df7247414130.tar.bz2
gentoo-2-1d1bcb769d8ace2e0fac9c1fe9a5df7247414130.zip
clean old impls, add pypy3, update test phase
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog5
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index de593fc1fc88..d730e1e62fdc 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.119 2014/11/24 13:47:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.120 2014/12/01 08:06:02 idella4 Exp $
+
+ 01 Dec 2014; Ian Delaney <idella4@gentoo.org> beautifulsoup-4.3.2.ebuild:
+ clean old impls, add pypy3, update test phase
24 Nov 2014; Pacho Ramos <pacho@gentoo.org> beautifulsoup-3.1.0.1-r2.ebuild:
Support python 3.4
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild
index 7c7c2cd4bb8d..21ae3d675d96 100644
--- a/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild,v 1.4 2014/04/02 21:11:35 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild,v 1.5 2014/12/01 08:06:02 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_{2,3,4}} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -37,9 +37,7 @@ python_compile_all() {
}
python_test() {
- # https://bugs.launchpad.net/beautifulsoup/+bug/1251451
- nosetests -w "${BUILD_DIR}"/lib -I test_lxml.py \
- || die "Tests fail with ${EPYTHON}"
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
}
python_install_all() {