summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-08 02:27:29 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-08 02:27:29 +0000
commit07aaa9a6137cd09ff0c6d1d267794684f65d1355 (patch)
treee439c6efbf23be0f1c1a9733c34eebd65d91a0a4 /dev-python/boto
parentfix broken whitespace -- no functional changes (diff)
downloadgentoo-2-07aaa9a6137cd09ff0c6d1d267794684f65d1355.tar.gz
gentoo-2-07aaa9a6137cd09ff0c6d1d267794684f65d1355.tar.bz2
gentoo-2-07aaa9a6137cd09ff0c6d1d267794684f65d1355.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.25.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 094b4a93b3be..ac4cdc53c17f 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.89 2014/01/30 08:05:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.90 2014/02/08 02:27:29 radhermit Exp $
+
+*boto-2.25.0 (08 Feb 2014)
+
+ 08 Feb 2014; Tim Harder <radhermit@gentoo.org> +boto-2.25.0.ebuild:
+ Version bump.
*boto-2.24.0 (30 Jan 2014)
diff --git a/dev-python/boto/boto-2.25.0.ebuild b/dev-python/boto/boto-2.25.0.ebuild
new file mode 100644
index 000000000000..601964c32570
--- /dev/null
+++ b/dev-python/boto/boto-2.25.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.25.0.ebuild,v 1.1 2014/02/08 02:27:29 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}