summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-09 02:05:37 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-09 02:05:37 +0000
commit1b464e69cff99b05ae5cbfc1a4317a825811ef66 (patch)
tree71566acffe2913494cc61ef39783411ecc2978e9 /dev-python/boto
parentBump. (diff)
downloadgentoo-2-1b464e69cff99b05ae5cbfc1a4317a825811ef66.tar.gz
gentoo-2-1b464e69cff99b05ae5cbfc1a4317a825811ef66.tar.bz2
gentoo-2-1b464e69cff99b05ae5cbfc1a4317a825811ef66.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.16.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index c60ab1018034..2912d8897795 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.75 2013/10/22 11:34:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.76 2013/11/09 02:05:37 radhermit Exp $
+
+*boto-2.16.0 (09 Nov 2013)
+
+ 09 Nov 2013; Tim Harder <radhermit@gentoo.org> +boto-2.16.0.ebuild:
+ Version bump.
22 Oct 2013; Fabian Groffen <grobian@gentoo.org> boto-2.15.0.ebuild:
Marked ~x64-macos, bug #487670
diff --git a/dev-python/boto/boto-2.16.0.ebuild b/dev-python/boto/boto-2.16.0.ebuild
new file mode 100644
index 000000000000..cfdfeaea36cf
--- /dev/null
+++ b/dev-python/boto/boto-2.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.16.0.ebuild,v 1.1 2013/11/09 02:05:37 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}