summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-20 01:08:51 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-20 01:08:51 +0000
commit83a62b0c622cf5d079901e3ef3fcdbec47f47794 (patch)
treece39afd64b0d1a16559c7508170a55d34c5d8a08 /dev-python/boto
parentAdd systemd unit file, bug #494708. Thanks Roc Vallès! (diff)
downloadgentoo-2-83a62b0c622cf5d079901e3ef3fcdbec47f47794.tar.gz
gentoo-2-83a62b0c622cf5d079901e3ef3fcdbec47f47794.tar.bz2
gentoo-2-83a62b0c622cf5d079901e3ef3fcdbec47f47794.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.21.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 6cd6e1c989d1..9348f8cae7aa 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.83 2013/12/17 11:01:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.84 2013/12/20 01:08:51 radhermit Exp $
+
+*boto-2.21.0 (20 Dec 2013)
+
+ 20 Dec 2013; Tim Harder <radhermit@gentoo.org> +boto-2.21.0.ebuild:
+ Version bump.
*boto-2.20.1 (17 Dec 2013)
diff --git a/dev-python/boto/boto-2.21.0.ebuild b/dev-python/boto/boto-2.21.0.ebuild
new file mode 100644
index 000000000000..ac730fd997f1
--- /dev/null
+++ b/dev-python/boto/boto-2.21.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.21.0.ebuild,v 1.1 2013/12/20 01:08:51 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}