summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-03 12:25:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-03 12:25:32 +0000
commit89f054c17a3207ef09f00b74ef4e167d3a5c1886 (patch)
treee87f90c994a8a8ca17ab0f464d41e9b55a3596ae /dev-python/cgkit
parentMaking CONFIG_CHECK non-fatal for userland ebuilds, see bug 283320. (diff)
downloadgentoo-2-89f054c17a3207ef09f00b74ef4e167d3a5c1886.tar.gz
gentoo-2-89f054c17a3207ef09f00b74ef4e167d3a5c1886.tar.bz2
gentoo-2-89f054c17a3207ef09f00b74ef4e167d3a5c1886.zip
Bump to alpha9, fixes #282896
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cgkit')
-rw-r--r--dev-python/cgkit/ChangeLog8
-rw-r--r--dev-python/cgkit/cgkit-2.0.0_alpha9.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index 4f348dc2cf60..234a9b00fd53 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cgkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.25 2009/08/16 20:42:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.26 2009/09/03 12:25:32 patrick Exp $
+
+*cgkit-2.0.0_alpha9 (03 Sep 2009)
+
+ 03 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +cgkit-2.0.0_alpha9.ebuild:
+ Bump to alpha9, fixes #282896
16 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
cgkit-2.0.0_alpha8.ebuild:
diff --git a/dev-python/cgkit/cgkit-2.0.0_alpha9.ebuild b/dev-python/cgkit/cgkit-2.0.0_alpha9.ebuild
new file mode 100644
index 000000000000..08b0632cf43b
--- /dev/null
+++ b/dev-python/cgkit/cgkit-2.0.0_alpha9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-2.0.0_alpha9.ebuild,v 1.1 2009/09/03 12:25:32 patrick Exp $
+
+inherit distutils flag-o-matic
+
+MY_P=${P/_/}
+DESCRIPTION="Python library for creating 3D images"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://cgkit.sourceforge.net"
+RDEPEND="dev-lang/python
+ dev-python/pyrex
+ dev-libs/boost
+ dev-python/pyprotocols
+ dev-python/pyopengl
+ dev-python/pygame
+ dev-python/imaging
+ 3ds? ( media-libs/lib3ds )"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MPL-1.1 GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3ds"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/fPIC/fPIC\",\"${CFLAGS// /\",\"}/" supportlib/SConstruct
+ cp config_template.cfg config.cfg
+ echo 'LIBS += ["GL", "GLU", "glut"]' >> config.cfg
+ if use 3ds; then
+ echo 'LIB3DS_AVAILABLE = True' >> config.cfg
+ fi
+
+ # Ogre viewer is no longer maintained by upstream
+ # bug 210731
+ #if use ogre; then
+ # echo 'OGRE_AVAILABLE = True' >> config.cfg
+ # echo 'INC_DIRS += ["/usr/include/OGRE"]' >> config.cfg
+ # echo 'MACROS += [("EXT_HASH", None),("GCC_3_1",None)]' >> config.cfg
+ # sed -i -e "s/#include <Math.h>//" wrappers/ogre/OgreCore.h
+ #fi
+
+ sed -i -e "s:INC_DIRS = \[\]:INC_DIRS = \['/usr/include'\]:" "${S}"/setup.py
+
+ sed -i -e "160s/as/as_/;168s/as/as_/" cgkit/flockofbirds.py
+}
+
+src_compile() {
+ cd "${S}"/supportlib
+ scons ${MAKEOPTS}
+ cd "${S}"
+ distutils_src_compile
+}
+
+src_test() {
+ cd unittests
+ # Remove failing tests due to non-existing files
+ rm test_maimport.py test_mayaascii.py test_mayabinary.py test_ri.py \
+ test_slparams.py
+ PYTHONPATH=$(ls -d ../build/lib*) ${python} all.py || die "tests failed"
+}