summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-07 15:10:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-07 15:10:38 +0000
commit3849726bb610d2f72895eb99f146bc53853bdd73 (patch)
treea4f4fc87bfb21b871d5d8dce44485745a5ed7bb5 /dev-python/chaco
parentnew ebuild, thanks to Andreis_Vinogradovs ( slepnoga ) <spamslepnoga@inbox.ru... (diff)
downloadgentoo-2-3849726bb610d2f72895eb99f146bc53853bdd73.tar.gz
gentoo-2-3849726bb610d2f72895eb99f146bc53853bdd73.tar.bz2
gentoo-2-3849726bb610d2f72895eb99f146bc53853bdd73.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/chaco-3.2.0.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/chaco/chaco-3.2.0.ebuild b/dev-python/chaco/chaco-3.2.0.ebuild
deleted file mode 100644
index 7e60fe3532f7..000000000000
--- a/dev-python/chaco/chaco-3.2.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.2.0.ebuild,v 1.3 2010/02/06 14:41:49 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="Chaco"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Interactive plotting toolkit"
-HOMEPAGE="http://code.enthought.com/projects/chaco"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-IUSE="doc examples"
-#IUSE="doc examples test"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
-
-RDEPEND=">=dev-python/enable-3.2.0"
-DEPEND="dev-python/setuptools
- >=dev-python/numpy-1.1
- doc? ( app-arch/unzip )"
-# docs building and tests need an X display
-# doc? ( dev-python/setupdocs )
-# test? ( >=dev-python/nose-0.10.3
-# dev-python/coverage
-# >=dev-python/enable-3.2.0
-# >=dev-python/enthoughtbase-3.0.3 )"
-RESTRICT_PYTHON_ABIS="3.*"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- sed -i -e "s/self.run_command('build_docs')/pass/" setup.py || die
-}
-
-src_compile() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils_src_compile
-
- #if use doc; then
- # "$(PYTHON -f)" setup.py build_docs --formats=html,pdf || die "Generation of documentation failed"
- #fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- python_execute_function testing
-}
-
-src_install() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils_src_install
- dodoc docs/*.txt
- insinto /usr/share/doc/${PF}
- if use doc; then
- #doins -r build/docs/html build/docs/latex/*.pdf || die
- doins docs/*.pdf || die
- unzip docs/html.zip
- insinto /usr/share/doc/${PF}
- doins -r html || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}