summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-11 03:34:00 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-11 03:34:00 +0000
commit83e8a4ce6457aee6893371c2845730ae907aa80e (patch)
tree7bbd91670c61722e957d0704d12695c3e295a336 /dev-python/cliff
parentBump for pyparsing-2.0.1. (diff)
downloadgentoo-2-83e8a4ce6457aee6893371c2845730ae907aa80e.tar.gz
gentoo-2-83e8a4ce6457aee6893371c2845730ae907aa80e.tar.bz2
gentoo-2-83e8a4ce6457aee6893371c2845730ae907aa80e.zip
adding cliff-1.4 now with more pyparsing
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/ChangeLog8
-rw-r--r--dev-python/cliff/cliff-1.4.ebuild (renamed from dev-python/cliff/cliff-1.3.ebuild)12
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-python/cliff/ChangeLog b/dev-python/cliff/ChangeLog
index b77436291e3a..37b6b17e7ff6 100644
--- a/dev-python/cliff/ChangeLog
+++ b/dev-python/cliff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cliff
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.2 2013/03/11 02:42:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.3 2013/08/11 03:34:00 prometheanfire Exp $
+
+*cliff-1.4 (11 Aug 2013)
+
+ 11 Aug 2013; Matthew Thode <prometheanfire@gentoo.org> +cliff-1.4.ebuild,
+ -cliff-1.3.ebuild:
+ adding cliff-1.4 now with more pyparsing
*cliff-1.3.1 (11 Mar 2013)
diff --git a/dev-python/cliff/cliff-1.3.ebuild b/dev-python/cliff/cliff-1.4.ebuild
index 75ffd8325928..e78a3da48f8c 100644
--- a/dev-python/cliff/cliff-1.3.ebuild
+++ b/dev-python/cliff/cliff-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.3.ebuild,v 1.1 2013/01/26 08:05:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.ebuild,v 1.1 2013/08/11 03:34:00 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 python3_2 )
@@ -18,5 +18,11 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- dev-python/prettytable
- dev-python/cmd2"
+ >=dev-python/prettytable-0.6
+ <dev-python/prettytable-0.8
+ >=dev-python/cmd2-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -i '29,37d' "setup.py" || die
+}