summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-08 22:02:34 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-08 22:02:34 +0000
commit80a24406a72090bfb2e3b3cecc1768c2dd9762a2 (patch)
treef3bc121f76e68348387519c889fc68e6503e7083 /dev-python/cryptography
parentAdd a slot operator on dev-python/cffi dep (bug #506552), and make it conditi... (diff)
downloadgentoo-2-80a24406a72090bfb2e3b3cecc1768c2dd9762a2.tar.gz
gentoo-2-80a24406a72090bfb2e3b3cecc1768c2dd9762a2.tar.bz2
gentoo-2-80a24406a72090bfb2e3b3cecc1768c2dd9762a2.zip
Add a slot operator on dev-python/cffi dep (bug #506552), and make it conditional to CPython implementations (PyPy has built-in cffi). Drop old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/ChangeLog10
-rw-r--r--dev-python/cryptography/cryptography-0.2.1.ebuild34
-rw-r--r--dev-python/cryptography/cryptography-0.2.2.ebuild34
-rw-r--r--dev-python/cryptography/cryptography-0.4-r1.ebuild (renamed from dev-python/cryptography/cryptography-0.3.ebuild)6
-rw-r--r--dev-python/cryptography/cryptography-0.4.ebuild35
5 files changed, 12 insertions, 107 deletions
diff --git a/dev-python/cryptography/ChangeLog b/dev-python/cryptography/ChangeLog
index 066728ff2601..fb76dcbacf90 100644
--- a/dev-python/cryptography/ChangeLog
+++ b/dev-python/cryptography/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/cryptography
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.12 2014/05/07 05:56:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.13 2014/05/08 22:02:34 mgorny Exp $
+
+*cryptography-0.4-r1 (08 May 2014)
+
+ 08 May 2014; Michał Górny <mgorny@gentoo.org> +cryptography-0.4-r1.ebuild,
+ -cryptography-0.2.1.ebuild, -cryptography-0.2.2.ebuild,
+ -cryptography-0.3.ebuild, -cryptography-0.4.ebuild:
+ Add a slot operator on dev-python/cffi dep (bug #506552), and make it
+ conditional to CPython implementations (PyPy has built-in cffi). Drop old.
*cryptography-0.4 (07 May 2014)
diff --git a/dev-python/cryptography/cryptography-0.2.1.ebuild b/dev-python/cryptography/cryptography-0.2.1.ebuild
deleted file mode 100644
index 97aba67c2b2e..000000000000
--- a/dev-python/cryptography/cryptography-0.2.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.2.1.ebuild,v 1.7 2014/03/31 20:59:29 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~x86 ~x86-fbsd"
-IUSE="test"
-
-RDEPEND="dev-libs/openssl:0
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- "${PYTHON}" -m pytest --verbose tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cryptography/cryptography-0.2.2.ebuild b/dev-python/cryptography/cryptography-0.2.2.ebuild
deleted file mode 100644
index e629eb31cd6c..000000000000
--- a/dev-python/cryptography/cryptography-0.2.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.2.2.ebuild,v 1.4 2014/04/03 08:43:13 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
-IUSE="test"
-
-RDEPEND="dev-libs/openssl:0
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cryptography/cryptography-0.3.ebuild b/dev-python/cryptography/cryptography-0.4-r1.ebuild
index 99920f9c0984..56719c803f67 100644
--- a/dev-python/cryptography/cryptography-0.3.ebuild
+++ b/dev-python/cryptography/cryptography-0.4-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.3.ebuild,v 1.2 2014/04/03 08:43:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.4-r1.ebuild,v 1.1 2014/05/08 22:02:34 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
inherit distutils-r1
@@ -18,7 +18,7 @@ IUSE="test"
RDEPEND="dev-libs/openssl:0
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.8[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' python*)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/cryptography/cryptography-0.4.ebuild b/dev-python/cryptography/cryptography-0.4.ebuild
deleted file mode 100644
index 5c37162fd4ef..000000000000
--- a/dev-python/cryptography/cryptography-0.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.4.ebuild,v 1.1 2014/05/07 05:56:43 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
-IUSE="test"
-
-RDEPEND="dev-libs/openssl:0
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- =dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}