summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-09-19 21:30:07 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-09-19 21:30:07 +0000
commit8f53234ba84051d13376d63b4c6910dd4b041898 (patch)
tree2f2771b00ea7e015cba5c1298aeff6131119517d /dev-python/ctypes
parentfix not installing anything bug (#148244) (diff)
downloadgentoo-2-8f53234ba84051d13376d63b4c6910dd4b041898.tar.gz
gentoo-2-8f53234ba84051d13376d63b4c6910dd4b041898.tar.bz2
gentoo-2-8f53234ba84051d13376d63b4c6910dd4b041898.zip
version bump for ctypes 1.0.0 (#147398)
(Portage version: 2.1.1)
Diffstat (limited to 'dev-python/ctypes')
-rw-r--r--dev-python/ctypes/ChangeLog8
-rw-r--r--dev-python/ctypes/ctypes-1.0.0.ebuild31
-rw-r--r--dev-python/ctypes/files/digest-ctypes-1.0.03
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/ctypes/ChangeLog b/dev-python/ctypes/ChangeLog
index c7969bb28de2..e3db8b289a1f 100644
--- a/dev-python/ctypes/ChangeLog
+++ b/dev-python/ctypes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ctypes
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.12 2006/09/09 12:33:10 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.13 2006/09/19 21:30:07 liquidx Exp $
+
+*ctypes-1.0.0 (19 Sep 2006)
+
+ 19 Sep 2006; Alastair Tse <liquidx@gentoo.org> -ctypes-0.9.9.3.ebuild,
+ +ctypes-1.0.0.ebuild:
+ version bump for ctypes 1.0.0 (#147398)
09 Sep 2006; Thomas Cort <tcort@gentoo.org> ctypes-0.9.9.6.ebuild:
Stable on amd64.
diff --git a/dev-python/ctypes/ctypes-1.0.0.ebuild b/dev-python/ctypes/ctypes-1.0.0.ebuild
new file mode 100644
index 000000000000..d39fc94644a0
--- /dev/null
+++ b/dev-python/ctypes/ctypes-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ctypes-1.0.0.ebuild,v 1.1 2006/09/19 21:30:07 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="Python module allowing to create and manipulate C data types."
+HOMEPAGE="http://starship.python.net/crew/theller/ctypes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3.3"
+
+DOCS="ACKS ANNOUNCE LICENSE.txt"
+
+src_test() {
+ mkdir "${T}/tests"
+ "${python}" setup.py install --home="${T}/tests"
+ PYTHONPATH="${T}/tests/$(get_libdir)/python" \
+ "${python}" ctypes/test/runtests.py || die "tests failed"
+ rm -rf "${T}/tests"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}/manual
+ doins -r docs/manual/*
+}
diff --git a/dev-python/ctypes/files/digest-ctypes-1.0.0 b/dev-python/ctypes/files/digest-ctypes-1.0.0
new file mode 100644
index 000000000000..491aed5c4e17
--- /dev/null
+++ b/dev-python/ctypes/files/digest-ctypes-1.0.0
@@ -0,0 +1,3 @@
+MD5 6e42e2fb47de008aaa55a840bb080dcd ctypes-1.0.0.tar.gz 383190
+RMD160 78e491068c5e9c8a0e26f749a1b6ccc8e76995ed ctypes-1.0.0.tar.gz 383190
+SHA256 b81441e55aa44d2cdaa8296295cd40ced0e5dc79d37c10760acfe965b4f94106 ctypes-1.0.0.tar.gz 383190