summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 02:17:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 02:17:14 +0000
commit207af40f5894ca288e84d972f6d846d3c98b1249 (patch)
tree7d65bbb1b8eb52f98d0927f69d1b6fb57831e30b /dev-python/cython/files
parentVersion bump. (diff)
downloadgentoo-2-207af40f5894ca288e84d972f6d846d3c98b1249.tar.gz
gentoo-2-207af40f5894ca288e84d972f6d846d3c98b1249.tar.bz2
gentoo-2-207af40f5894ca288e84d972f6d846d3c98b1249.zip
Fix building with Python 3.1.3 (bug #344823).
(Portage version: 2.2.0_alpha4_p23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cython/files')
-rw-r--r--dev-python/cython/files/cython-0.13-python-3.1.3.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cython/files/cython-0.13-python-3.1.3.patch b/dev-python/cython/files/cython-0.13-python-3.1.3.patch
new file mode 100644
index 000000000000..19e30bef11e1
--- /dev/null
+++ b/dev-python/cython/files/cython-0.13-python-3.1.3.patch
@@ -0,0 +1,25 @@
+http://hg.cython.org/cython-devel/rev/66db6308e5be
+
+--- setup.py
++++ setup.py
+@@ -106,12 +106,19 @@
+ )
+
+ class build_ext(build_ext_orig):
++ # we must keep the original modules alive to make sure
++ # their code keeps working when we remove them from
++ # sys.modules
++ dead_modules = []
++
+ def build_extensions(self):
+ # add path where 2to3 installed the transformed sources
+ # and make sure Python (re-)imports them from there
+ already_imported = [ module for module in sys.modules
+ if module == 'Cython' or module.startswith('Cython.') ]
++ keep_alive = self.dead_modules.append
+ for module in already_imported:
++ keep_alive(sys.modules[module])
+ del sys.modules[module]
+ sys.path.insert(0, os.path.join(source_root, self.build_lib))
+
+