summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-02 02:50:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-02 02:50:24 +0000
commite07d9c6f419d858a63ce0aa38d21f381cffe7511 (patch)
tree5c033f4b29d49c92d6a5430a79255aec4e4449ad /dev-python/deform
parentStable for HPPA (bug #486002). (diff)
downloadgentoo-2-e07d9c6f419d858a63ce0aa38d21f381cffe7511.tar.gz
gentoo-2-e07d9c6f419d858a63ce0aa38d21f381cffe7511.tar.bz2
gentoo-2-e07d9c6f419d858a63ce0aa38d21f381cffe7511.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/deform')
-rw-r--r--dev-python/deform/ChangeLog7
-rw-r--r--dev-python/deform/deform-0.9.9.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/deform/ChangeLog b/dev-python/deform/ChangeLog
index 63062400e0c7..11c686003c65 100644
--- a/dev-python/deform/ChangeLog
+++ b/dev-python/deform/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/deform
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.10 2013/09/02 19:07:27 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.11 2013/10/02 02:50:24 patrick Exp $
+
+*deform-0.9.9 (02 Oct 2013)
+
+ 02 Oct 2013; Patrick Lauer <patrick@gentoo.org> +deform-0.9.9.ebuild:
+ Bump
02 Sep 2013; Mike Gilbert <floppym@gentoo.org> -deform-0.9.2.ebuild,
-deform-0.9.3.ebuild, -deform-0.9.4.ebuild, -deform-0.9.5.ebuild,
diff --git a/dev-python/deform/deform-0.9.9.ebuild b/dev-python/deform/deform-0.9.9.ebuild
new file mode 100644
index 000000000000..e4fdda3ef5b0
--- /dev/null
+++ b/dev-python/deform/deform-0.9.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.9.ebuild,v 1.1 2013/10/02 02:50:24 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+inherit distutils-r1
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests require zope.deprecation
+RESTRICT="test"
+
+RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]
+ >=dev-python/colander-1.0_alpha1[${PYTHON_USEDEP}]
+ >=dev-python/peppercorn-0.4[${PYTHON_USEDEP}]
+ >=dev-python/chameleon-1.2.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup:4[${PYTHON_USEDEP}] )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
+}