summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-17 05:43:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-17 05:43:58 +0000
commitf40289b46e732db80773951d764c06f0c780db97 (patch)
tree22c2b304ec8c16473c358678d25cff1317287f79 /dev-python/deform
parentBump (diff)
downloadgentoo-2-f40289b46e732db80773951d764c06f0c780db97.tar.gz
gentoo-2-f40289b46e732db80773951d764c06f0c780db97.tar.bz2
gentoo-2-f40289b46e732db80773951d764c06f0c780db97.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/deform')
-rw-r--r--dev-python/deform/ChangeLog7
-rw-r--r--dev-python/deform/deform-0.9.7.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/deform/ChangeLog b/dev-python/deform/ChangeLog
index 6b5ebcd6bb6c..e87dba7972e8 100644
--- a/dev-python/deform/ChangeLog
+++ b/dev-python/deform/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/deform
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.7 2013/01/31 09:45:18 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.8 2013/03/17 05:43:58 patrick Exp $
+
+*deform-0.9.7 (17 Mar 2013)
+
+ 17 Mar 2013; Patrick Lauer <patrick@gentoo.org> +deform-0.9.7.ebuild:
+ Bump
*deform-0.9.6-r1 (31 Jan 2013)
diff --git a/dev-python/deform/deform-0.9.7.ebuild b/dev-python/deform/deform-0.9.7.ebuild
new file mode 100644
index 000000000000..69cc2ba21b37
--- /dev/null
+++ b/dev-python/deform/deform-0.9.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.7.ebuild,v 1.1 2013/03/17 05:43:58 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} python3_2 pypy{1_9,2_0} )
+inherit distutils-r1
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests require zope.deprecation
+RESTRICT="test"
+
+# Depend on peppercorn, translationstring and colander with Python 3 support
+RDEPEND=">=dev-python/translationstring-1.1
+ >=dev-python/colander-1.0_alpha1
+ >=dev-python/peppercorn-0.4
+ >=dev-python/chameleon-1.2.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup:4 )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
+}