summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-07 06:40:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-07 06:40:25 +0000
commitc300663ba4424f4fe200e007702d166a713e964a (patch)
tree61d0072ea9ba46ec9ce50754fd90c81a25c440b8 /dev-python/django-pipeline
parentRespect CC, CFLAGS, LDFLAGS for tests. Don't automatically enable ccache. Hop... (diff)
downloadgentoo-2-c300663ba4424f4fe200e007702d166a713e964a.tar.gz
gentoo-2-c300663ba4424f4fe200e007702d166a713e964a.tar.bz2
gentoo-2-c300663ba4424f4fe200e007702d166a713e964a.zip
bump; add pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/ChangeLog9
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.9.ebuild68
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.16.ebuild46
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.17.ebuild4
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.18.ebuild (renamed from dev-python/django-pipeline/django-pipeline-1.3.15.ebuild)8
5 files changed, 14 insertions, 121 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index 6061d88ae513..779b0a03bde9 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/django-pipeline
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.22 2014/05/03 09:33:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.23 2014/06/07 06:40:25 idella4 Exp $
+
+*django-pipeline-1.3.18 (07 Jun 2014)
+
+ 07 Jun 2014; Ian Delaney <idella4@gentoo.org> +django-pipeline-1.3.18.ebuild,
+ -django-pipeline-1.2.9.ebuild, -django-pipeline-1.3.15.ebuild,
+ -django-pipeline-1.3.16.ebuild, django-pipeline-1.3.17.ebuild:
+ bump; add pypy support
*django-pipeline-1.3.17 (03 May 2014)
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
deleted file mode 100644
index 1ee3b6f9b12d..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild,v 1.7 2014/04/26 13:16:03 idella4 Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
-
-inherit distutils
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 ~x86"
-IUSE="doc"
-
-LICENSE="MIT"
-SLOT="0"
-PYTHON_MODNAME="pipeline"
-DISTUTILS_SRC_TEST=nosetests
-RDEPEND=">=dev-python/django-1.4"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-src_compile() {
- use doc && emake -C docs html
- rm -f docs/_build/doctrees/environment.pickle || die
- distutils_src_compile
-}
-
-src_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- # Python.[56] trigger a harmless deprecation warning
- testing() {
- local exit_status=0 test
- pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
- PYTHONPATH=.
- for test in [a-z]*.py
- do
- if ! "$(PYTHON)" ${test}; then
- eerror "test "${test}" failed"
- exit_status="1"
- else
- einfo "test "${test}" passed OK"
- fi
- done
- popd > /dev/null
- return ${exit_status}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-
- # Remove un-needed tests to avoid file collisions
- rmtests() {
- rm -rf "${ED}"/$(python_get_sitedir)/tests/ || die
- }
-
- python_execute_function rmtests
-}
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild
deleted file mode 100644
index 3fe821850545..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild,v 1.1 2014/04/26 13:16:03 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
-
-# PyPi releases lack docs/ subdir:
-# https://github.com/cyberdelia/django-pipeline/pull/254
-SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/django-1.5.5[${PYTHON_USEDEP}]
- dev-python/jsmin[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? (
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-# As usual for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
- || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild
index c179cd9a7834..8df91e607874 100644
--- a/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild,v 1.1 2014/05/03 09:33:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.17.ebuild,v 1.2 2014/06/07 06:40:25 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -24,7 +24,7 @@ RDEPEND=">=dev-python/django-1.5.6[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.18.ebuild
index 7723da91737b..a415b3f3c613 100644
--- a/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.3.18.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild,v 1.4 2014/04/26 12:25:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.18.ebuild,v 1.1 2014/06/07 06:40:25 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -19,12 +19,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
-RDEPEND=">=dev-python/django-1.4.1[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/django-1.5.6[${PYTHON_USEDEP}]
dev-python/jsmin[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"