summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-17 06:17:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-17 06:17:57 +0000
commit3488fc169b8b806b340897e4804ff0b465d17034 (patch)
tree41734375c3b941cef818abbcf5e876122c521b0a /dev-python/django
parentMark m68k/s390/sh stable. (diff)
downloadgentoo-2-3488fc169b8b806b340897e4804ff0b465d17034.tar.gz
gentoo-2-3488fc169b8b806b340897e4804ff0b465d17034.tar.bz2
gentoo-2-3488fc169b8b806b340897e4804ff0b465d17034.zip
bump; re-base of objects.patch, fix testsuite with sed statement, thanks to Arfrever, fixes Bug #491318
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog11
-rw-r--r--dev-python/django/django-1.6.1.ebuild91
-rw-r--r--dev-python/django/files/django-1.6-objects.patch18
3 files changed, 118 insertions, 2 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 357b361ac7c8..f42da09c631a 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/django
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.120 2013/12/03 01:34:41 creffett Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.121 2014/01/17 06:17:57 idella4 Exp $
+
+*django-1.6.1 (17 Jan 2014)
+
+ 17 Jan 2014; Ian Delaney <idella4@gentoo.org> +django-1.6.1.ebuild,
+ +files/django-1.6-objects.patch:
+ bump; re-base of objects.patch, fix testsuite with sed statement, thanks to
+ Arfrever, fixes Bug #491318
03 Dec 2013; Chris Reffett <creffett@gentoo.org> -django-1.4.5.ebuild,
-django-1.5.1.ebuild:
diff --git a/dev-python/django/django-1.6.1.ebuild b/dev-python/django/django-1.6.1.ebuild
new file mode 100644
index 000000000000..c3f56a9d162c
--- /dev/null
+++ b/dev-python/django/django-1.6.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.6.1.ebuild,v 1.1 2014/01/17 06:17:57 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE='sqlite?'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 versionator webapp
+
+MY_P="Django-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
+SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite test"
+
+PY2_USEDEP=$(python_gen_usedep 'python2*')
+RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+ test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5-py3tests.patch \
+ "${FILESDIR}"/${PN}-1.6-objects.patch )
+
+python_prepare_all() {
+ # Avoid test failures with unittest2 and Python 3.
+ sed -e "s/from unittest2 import \*/raise ImportError/" -i django/utils/unittest/__init__.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ # https://code.djangoproject.com/ticket/20514
+ # https://code.djangoproject.com/ticket/21093
+
+ sed -e 's:test_dont_base64_encode:_&:' -i tests/mail/tests.py || die
+ PYTHONPATH=. \
+ "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ # Port conflict in django.test.testcases.LiveServerTestCase.
+ # Several other races with temp files.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+ webapp_src_install
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ local HTML_DOCS=( docs/_build/html/. )
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/static/admin/.
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
+}
diff --git a/dev-python/django/files/django-1.6-objects.patch b/dev-python/django/files/django-1.6-objects.patch
new file mode 100644
index 000000000000..597da6e6bb1c
--- /dev/null
+++ b/dev-python/django/files/django-1.6-objects.patch
@@ -0,0 +1,18 @@
+#Remove un-needed objects.inv files from d'loading during doc build
+diff -ur Django-1.6.1.orig/docs/conf.py Django-1.6.1/docs/conf.py
+--- docs/conf.py 2013-12-12 14:37:59.000000000 -0500
++++ docs/conf.py 2014-01-16 20:57:36.253670094 -0500
+@@ -109,12 +109,6 @@
+
+ # Links to Python's docs should reference the most recent version of the 2.x
+ # branch, which is located at this URL.
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/2.7', None),
+- 'sphinx': ('http://sphinx.pocoo.org/', None),
+- 'six': ('http://pythonhosted.org/six/', None),
+- 'simplejson': ('http://simplejson.readthedocs.org/en/latest/', None),
+-}
+
+ # Python's docs don't change every week.
+ intersphinx_cache_limit = 90 # days
+