summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-06 06:05:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-06 06:05:59 +0000
commitc6db0798182ea2ae66707657ceb4646d6b35bf8d (patch)
tree3b8daa92d451dbe296d6d36f74543f6540bc7db3 /dev-python/dugong
parentRe-add -2.0, reverse dep on blohg (diff)
downloadgentoo-2-c6db0798182ea2ae66707657ceb4646d6b35bf8d.tar.gz
gentoo-2-c6db0798182ea2ae66707657ceb4646d6b35bf8d.tar.bz2
gentoo-2-c6db0798182ea2ae66707657ceb4646d6b35bf8d.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/ChangeLog9
-rw-r--r--dev-python/dugong/dugong-3.1.ebuild4
-rw-r--r--dev-python/dugong/dugong-3.2.ebuild33
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/dugong/ChangeLog b/dev-python/dugong/ChangeLog
index 5066b85ba015..29e17cf1d516 100644
--- a/dev-python/dugong/ChangeLog
+++ b/dev-python/dugong/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dugong
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.3 2014/06/29 02:33:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.4 2014/08/06 06:05:59 idella4 Exp $
+
+*dugong-3.2 (06 Aug 2014)
+
+ 06 Aug 2014; Ian Delaney <idella4@gentoo.org> +dugong-3.2.ebuild,
+ dugong-3.1.ebuild:
+ bump
*dugong-3.1 (29 Jun 2014)
@@ -17,4 +23,3 @@
17 Mar 2014; Tim Harder <radhermit@gentoo.org> +dugong-2.2.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/dev-python/dugong/dugong-3.1.ebuild b/dev-python/dugong/dugong-3.1.ebuild
index cdb061b50ce8..1af302fecd4e 100644
--- a/dev-python/dugong/dugong-3.1.ebuild
+++ b/dev-python/dugong/dugong-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.1.ebuild,v 1.1 2014/06/29 02:33:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.1.ebuild,v 1.2 2014/08/06 06:05:59 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python3_{3,4} )
@@ -20,6 +20,8 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
+ # This test hangs
+ sed -e 's:test_blocking_send:_&:' -i test/test_dugong.py || die
py.test -v || die "Tests failed under ${EPYTHON}"
}
diff --git a/dev-python/dugong/dugong-3.2.ebuild b/dev-python/dugong/dugong-3.2.ebuild
new file mode 100644
index 000000000000..82dd4c7f6377
--- /dev/null
+++ b/dev-python/dugong/dugong-3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.2.ebuild,v 1.1 2014/08/06 06:05:59 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/nikratio/python-dugong/issue/12
+ # This test hangs
+ sed -e 's:test_blocking_send:_&:' -i test/test_dugong.py || die
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}