summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-07 13:54:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-07 13:54:34 +0000
commitb6e2aa4cb7e02409ff002995dd4a32b303694f8c (patch)
tree9addbd6d24c5e5f2398bc86b9a34bdd63788381a /dev-python/eyeD3
parentRemoved vulnerable versions, bug #393475 (diff)
downloadgentoo-2-b6e2aa4cb7e02409ff002995dd4a32b303694f8c.tar.gz
gentoo-2-b6e2aa4cb7e02409ff002995dd4a32b303694f8c.tar.bz2
gentoo-2-b6e2aa4cb7e02409ff002995dd4a32b303694f8c.zip
version bump
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/ChangeLog7
-rw-r--r--dev-python/eyeD3/eyeD3-0.6.18.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/eyeD3/ChangeLog b/dev-python/eyeD3/ChangeLog
index c93c338f69c7..656037eb17ff 100644
--- a/dev-python/eyeD3/ChangeLog
+++ b/dev-python/eyeD3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/eyeD3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.45 2011/10/31 19:59:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.46 2011/12/07 13:54:34 aballier Exp $
+
+*eyeD3-0.6.18 (07 Dec 2011)
+
+ 07 Dec 2011; Alexis Ballier <aballier@gentoo.org> +eyeD3-0.6.18.ebuild:
+ version bump
31 Oct 2011; Markos Chandras <hwoarang@gentoo.org> eyeD3-0.6.17.ebuild:
Fix installation of eyeD3 script. Patch by Arfrever.
diff --git a/dev-python/eyeD3/eyeD3-0.6.18.ebuild b/dev-python/eyeD3/eyeD3-0.6.18.ebuild
new file mode 100644
index 000000000000..dc9b8e312ae9
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.6.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.6.18.ebuild,v 1.1 2011/12/07 13:54:34 aballier Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="http://eyed3.nicfit.net/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_configure() {
+ python_execute_function -d -f -q
+}
+
+src_install() {
+ dohtml *.html && rm -f *.html
+ distutils_src_install
+
+ install_script() {
+ mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ cp bin/eyeD3 "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ }
+ python_execute_function -q install_script
+ python_merge_intermediate_installation_images "${T}/images"
+
+ doman doc/*.1
+}