summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-09 15:18:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-09 15:18:02 +0000
commit39159b57298c082c7026cc634b89e297de432231 (patch)
tree08540e532de85cd3f9401a6747d4508a787d6bbd /dev-python/fabric
parentAutomated update. (diff)
downloadgentoo-2-39159b57298c082c7026cc634b89e297de432231.tar.gz
gentoo-2-39159b57298c082c7026cc634b89e297de432231.tar.bz2
gentoo-2-39159b57298c082c7026cc634b89e297de432231.zip
bump; patch to fox doc build
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/ChangeLog8
-rw-r--r--dev-python/fabric/fabric-1.8.3.ebuild49
-rw-r--r--dev-python/fabric/files/doc-extensions.patch13
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/fabric/ChangeLog b/dev-python/fabric/ChangeLog
index 7e3517768c24..1473f8d2bfa9 100644
--- a/dev-python/fabric/ChangeLog
+++ b/dev-python/fabric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fabric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.42 2014/03/31 08:31:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.43 2014/04/09 15:18:02 idella4 Exp $
+
+*fabric-1.8.3 (09 Apr 2014)
+
+ 09 Apr 2014; Ian Delaney <idella4@gentoo.org> +fabric-1.8.3.ebuild,
+ +files/doc-extensions.patch:
+ bump; patch to fox doc build
*fabric-1.8.2 (31 Mar 2014)
diff --git a/dev-python/fabric/fabric-1.8.3.ebuild b/dev-python/fabric/fabric-1.8.3.ebuild
new file mode 100644
index 000000000000..b1c8c0a13f95
--- /dev/null
+++ b/dev-python/fabric/fabric-1.8.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.8.3.ebuild,v 1.1 2014/04/09 15:18:02 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple pythonic tool for remote execution and deployment."
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="<dev-python/paramiko-1.13[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( <dev-python/fudge-1.0[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/doc-extensions.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fabric/files/doc-extensions.patch b/dev-python/fabric/files/doc-extensions.patch
new file mode 100644
index 000000000000..e426d6197b36
--- /dev/null
+++ b/dev-python/fabric/files/doc-extensions.patch
@@ -0,0 +1,13 @@
+releases module cannot be found and would cause un-needed d'loading
+diff -ur Fabric-1.8.3.orig/docs/conf.py Fabric-1.8.3/docs/conf.py
+--- docs/conf.py 2014-02-15 01:28:56.000000000 +0800
++++ docs/conf.py 2014-04-09 22:55:42.851674861 +0800
+@@ -26,7 +26,7 @@
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'releases']
++extensions = ['sphinx.ext.autodoc']
+
+ # 'releases' (changelog) settings
+ releases_issue_uri = "https://github.com/fabric/fabric/issues/%s"