summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-10 10:13:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-10 10:13:03 +0000
commit3294fccea1048213bc53a8aded3aa9130555f666 (patch)
tree7ad90e3c1b023687cddac5f0990f8ef827b87fc9 /dev-python/flask-babel/flask-babel-0.9.ebuild
parentAdd mistakenly removed GNOME2_LA_PUNT, bug #480166. (diff)
downloadgentoo-2-3294fccea1048213bc53a8aded3aa9130555f666.tar.gz
gentoo-2-3294fccea1048213bc53a8aded3aa9130555f666.tar.bz2
gentoo-2-3294fccea1048213bc53a8aded3aa9130555f666.zip
Bump
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-babel/flask-babel-0.9.ebuild')
-rw-r--r--dev-python/flask-babel/flask-babel-0.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-babel/flask-babel-0.9.ebuild b/dev-python/flask-babel/flask-babel-0.9.ebuild
new file mode 100644
index 000000000000..478b42b4bf25
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/flask-babel-0.9.ebuild,v 1.1 2013/08/10 10:13:03 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Babel"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="http://packages.python.org/Flask-Babel/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}