summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-19 07:55:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-19 07:55:06 +0000
commitc3eb72960341f2f5eec995567df0d2afc53778fd (patch)
tree36b9679e2900ed155fcf6226c8293fad17ea3e0a /dev-python/flask-babel
parentAdd newest version of lv dictionary (even if the version string is lower). (diff)
downloadgentoo-2-c3eb72960341f2f5eec995567df0d2afc53778fd.tar.gz
gentoo-2-c3eb72960341f2f5eec995567df0d2afc53778fd.tar.bz2
gentoo-2-c3eb72960341f2f5eec995567df0d2afc53778fd.zip
Bump
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/ChangeLog9
-rw-r--r--dev-python/flask-babel/flask-babel-0.8.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/flask-babel/ChangeLog b/dev-python/flask-babel/ChangeLog
index 68c599b0e36c..13c509a1f6a2 100644
--- a/dev-python/flask-babel/ChangeLog
+++ b/dev-python/flask-babel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-babel
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/ChangeLog,v 1.3 2011/09/08 07:12:00 rafaelmartins Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/ChangeLog,v 1.4 2012/04/19 07:55:06 patrick Exp $
+
+*flask-babel-0.8 (19 Apr 2012)
+
+ 19 Apr 2012; Patrick Lauer <patrick@gentoo.org> +flask-babel-0.8.ebuild:
+ Bump
*flask-babel-0.7 (08 Sep 2011)
diff --git a/dev-python/flask-babel/flask-babel-0.8.ebuild b/dev-python/flask-babel/flask-babel-0.8.ebuild
new file mode 100644
index 000000000000..e835c8915143
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/flask-babel-0.8.ebuild,v 1.1 2012/04/19 07:55:06 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Flask-Babel"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="http://packages.python.org/Flask-Babel/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/flask
+ dev-python/Babel
+ dev-python/pytz
+ >=dev-python/speaklater-1.2
+ >=dev-python/jinja-2.5"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flaskext/babel.py"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ emake -C docs html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}