summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-18 02:59:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-18 02:59:11 +0000
commit9ad874b9214c2befed0ff26ab5a58050ef085e8a (patch)
tree1babab8ec69866854ad673243c87f60125c39df1 /dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
parentApply previous change to the live ebuild. (diff)
downloadgentoo-2-9ad874b9214c2befed0ff26ab5a58050ef085e8a.tar.gz
gentoo-2-9ad874b9214c2befed0ff26ab5a58050ef085e8a.tar.bz2
gentoo-2-9ad874b9214c2befed0ff26ab5a58050ef085e8a.zip
Initial import, ebuild by me
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-peewee/flask-peewee-0.6.5.ebuild')
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
new file mode 100644
index 000000000000..d9119a31406f
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild,v 1.1 2013/08/18 02:59:11 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}