summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-25 05:17:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-25 05:17:54 +0000
commit2829058638030b4485d7ba5e7d9a0e72d5d3b313 (patch)
tree258cee49d2cab83429fb6fc7f65fa0f02e2f120e /dev-python/flask-restful
parentRe-add parrot/nqp backend as nqp works again (diff)
downloadgentoo-2-2829058638030b4485d7ba5e7d9a0e72d5d3b313.tar.gz
gentoo-2-2829058638030b4485d7ba5e7d9a0e72d5d3b313.tar.bz2
gentoo-2-2829058638030b4485d7ba5e7d9a0e72d5d3b313.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/ChangeLog7
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/flask-restful/ChangeLog b/dev-python/flask-restful/ChangeLog
index 9532359fbef9..59fcd0430cd0 100644
--- a/dev-python/flask-restful/ChangeLog
+++ b/dev-python/flask-restful/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-restful
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restful/ChangeLog,v 1.2 2014/11/24 21:00:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restful/ChangeLog,v 1.3 2014/11/25 05:17:54 patrick Exp $
+
+*flask-restful-0.3.0 (25 Nov 2014)
+
+ 25 Nov 2014; Patrick Lauer <patrick@gentoo.org> +flask-restful-0.3.0.ebuild:
+ Bump
24 Nov 2014; Pacho Ramos <pacho@gentoo.org> flask-restful-0.2.12.ebuild:
Support python 3.4
diff --git a/dev-python/flask-restful/flask-restful-0.3.0.ebuild b/dev-python/flask-restful/flask-restful-0.3.0.ebuild
new file mode 100644
index 000000000000..605b8e640b8a
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restful/flask-restful-0.3.0.ebuild,v 1.1 2014/11/25 05:17:54 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="http://flask-restful.readthedocs.org/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}