summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-06 10:13:21 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-06 10:13:21 +0000
commit418b9fb3008758c5c47e25da72c365e07651474c (patch)
tree62c5a71e63d123bf3643a3d40344e99c02b7d9b6 /dev-python/flask-restless
parentBump (diff)
downloadgentoo-2-418b9fb3008758c5c47e25da72c365e07651474c.tar.gz
gentoo-2-418b9fb3008758c5c47e25da72c365e07651474c.tar.bz2
gentoo-2-418b9fb3008758c5c47e25da72c365e07651474c.zip
bump; drop py2.6 add pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/ChangeLog8
-rw-r--r--dev-python/flask-restless/files/mapping.patch13
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.0.ebuild4
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.1.ebuild60
4 files changed, 82 insertions, 3 deletions
diff --git a/dev-python/flask-restless/ChangeLog b/dev-python/flask-restless/ChangeLog
index 0b9898aff05b..f0e8a459fb36 100644
--- a/dev-python/flask-restless/ChangeLog
+++ b/dev-python/flask-restless/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flask-restless
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.9 2014/01/21 04:11:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.10 2014/05/06 10:13:21 idella4 Exp $
+
+*flask-restless-0.12.1 (06 May 2014)
+
+ 06 May 2014; Ian Delaney <idella4@gentoo.org> +files/mapping.patch,
+ +flask-restless-0.12.1.ebuild, flask-restless-0.12.0.ebuild:
+ bump; drop py2.6 add pypy support
21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -flask-restless-0.10.0.ebuild,
-flask-restless-0.10.1.ebuild, -flask-restless-0.11.0-r1.ebuild:
diff --git a/dev-python/flask-restless/files/mapping.patch b/dev-python/flask-restless/files/mapping.patch
new file mode 100644
index 000000000000..725a20d828f6
--- /dev/null
+++ b/dev-python/flask-restless/files/mapping.patch
@@ -0,0 +1,13 @@
+A number of these settings are simply unworkable in gentoo
+diff -ur flask-restless-0.11.0.orig/docs/conf.py flask-restless-0.11.0/docs/conf.py
+--- docs/conf.py 2013-05-19 01:50:21.000000000 +0800
++++ docs/conf.py 2013-06-10 23:39:05.741199580 +0800
+@@ -26,7 +26,7 @@
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx']
++extensions = ['sphinx.ext.autodoc']
+ extensions += ['sphinxcontrib.httpdomain']
+ extensions += ['sphinxcontrib.issuetracker']
+
diff --git a/dev-python/flask-restless/flask-restless-0.12.0.ebuild b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
index 85c9d9f40dbd..9ef6806bca90 100644
--- a/dev-python/flask-restless/flask-restless-0.12.0.ebuild
+++ b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v 1.1 2013/11/22 07:13:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v 1.2 2014/05/06 10:13:21 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
diff --git a/dev-python/flask-restless/flask-restless-0.12.1.ebuild b/dev-python/flask-restless/flask-restless-0.12.1.ebuild
new file mode 100644
index 000000000000..351106509abf
--- /dev/null
+++ b/dev-python/flask-restless/flask-restless-0.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.1.ebuild,v 1.1 2014/05/06 10:13:21 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="Flask extension for easy ReSTful API generation"
+HOMEPAGE="http://packages.python.org/Flask-Restless/"
+SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( AGPL-3 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
+ dev-python/flask-themes[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+python_compile_all() {
+ if use doc; then
+ if ! "${PYTHON}" -c "import flask_restless"; then
+ eerror "flask-restless is not installed. Building of the docs"
+ eerror "requires flask-restless to be installed."
+ eerror "emerge with USE=-doc followed bu USE=doc"
+ die
+ fi
+ # Changes connect to read issues @ github
+ rm -f docs/changelog.rst
+ einfo "Generating html docs for ${PN}"
+ PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
+ || die "Generating html docs for ${PN} failed"
+ fi
+}
+
+python_test() {
+ nosetests -w tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}