summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-21 10:42:54 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-21 10:42:54 +0000
commit326b9d5affa7009e8a0403c686bbe9fbd8b1a411 (patch)
treeb22db3854c0c6eab83019fd0643dece89b99d859 /dev-python/flask-wtf
parentRemove -L$(libdir) from LIBS (maybe bug #533164). (diff)
downloadgentoo-2-326b9d5affa7009e8a0403c686bbe9fbd8b1a411.tar.gz
gentoo-2-326b9d5affa7009e8a0403c686bbe9fbd8b1a411.tar.bz2
gentoo-2-326b9d5affa7009e8a0403c686bbe9fbd8b1a411.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/ChangeLog7
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.0.ebuild49
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.1.ebuild52
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.9.3.ebuild38
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.9.4.ebuild38
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.9.5.ebuild50
6 files changed, 6 insertions, 228 deletions
diff --git a/dev-python/flask-wtf/ChangeLog b/dev-python/flask-wtf/ChangeLog
index 62609e8f340f..e721e5aef385 100644
--- a/dev-python/flask-wtf/ChangeLog
+++ b/dev-python/flask-wtf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-wtf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.17 2014/11/21 05:20:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.18 2014/12/21 10:42:54 idella4 Exp $
+
+ 21 Dec 2014; Ian Delaney <idella4@gentoo.org> -flask-wtf-0.10.0.ebuild,
+ -flask-wtf-0.10.1.ebuild, -flask-wtf-0.9.3.ebuild, -flask-wtf-0.9.4.ebuild,
+ -flask-wtf-0.9.5.ebuild:
+ rm old
*flask-wtf-0.10.3 (21 Nov 2014)
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild
deleted file mode 100644
index c302e828b275..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild,v 1.2 2014/08/10 21:11:07 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild
deleted file mode 100644
index 1f5875c654d2..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild,v 1.1 2014/08/28 06:33:18 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-# silly captcha test trying to access things over the network
-RESTRICT="test"
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.9.3.ebuild b/dev-python/flask-wtf/flask-wtf-0.9.3.ebuild
deleted file mode 100644
index 1ae2191b343e..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.9.3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.9.3.ebuild,v 1.2 2014/08/10 21:11:07 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.9.4.ebuild b/dev-python/flask-wtf/flask-wtf-0.9.4.ebuild
deleted file mode 100644
index eedab3c82ac8..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.9.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.9.4.ebuild,v 1.2 2014/08/10 21:11:07 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.9.5.ebuild b/dev-python/flask-wtf/flask-wtf-0.9.5.ebuild
deleted file mode 100644
index dddd7bec01a6..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.9.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.9.5.ebuild,v 1.3 2014/08/10 21:11:07 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
- <dev-python/wtforms-2.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}