summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-28 06:33:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-28 06:33:18 +0000
commit3a562c1df6cd7d0f3df602a225a59f4756029293 (patch)
tree879a1fe19961806389299f28d1ba2c5575cb6179 /dev-python/flask-wtf
parentold (diff)
downloadgentoo-2-3a562c1df6cd7d0f3df602a225a59f4756029293.tar.gz
gentoo-2-3a562c1df6cd7d0f3df602a225a59f4756029293.tar.bz2
gentoo-2-3a562c1df6cd7d0f3df602a225a59f4756029293.zip
Bump
(Portage version: 2.2.12/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/ChangeLog7
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/flask-wtf/ChangeLog b/dev-python/flask-wtf/ChangeLog
index 6a4f08cdc0d7..4a0d4ab3dd67 100644
--- a/dev-python/flask-wtf/ChangeLog
+++ b/dev-python/flask-wtf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-wtf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.14 2014/08/10 21:11:07 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.15 2014/08/28 06:33:18 patrick Exp $
+
+*flask-wtf-0.10.1 (28 Aug 2014)
+
+ 28 Aug 2014; Patrick Lauer <patrick@gentoo.org> +flask-wtf-0.10.1.ebuild:
+ Bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> flask-wtf-0.10.0.ebuild,
flask-wtf-0.9.3.ebuild, flask-wtf-0.9.4.ebuild, flask-wtf-0.9.5.ebuild:
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild
new file mode 100644
index 000000000000..1f5875c654d2
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.10.1.ebuild,v 1.1 2014/08/28 06:33:18 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+# silly captcha test trying to access things over the network
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}